Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1)ввести с клавиатуры массив А из 5 элементов, найти минимальное из них 2)умножить все элементы массива А на 2 3)найти среднее

5-9 класс

арифметическое всех элементов массива a

Dasha20012111 10 окт. 2014 г., 5:23:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Бананчик2003
10 окт. 2014 г., 8:05:55 (9 лет назад)

begin
read(n);
for i:=1 to n do
readln(a[i]):
min:=a[1];
for i:=2 to n do begin
if a[i]>max then max:=a[i];
writeln(a[i])
end;
for i:=1 to n do begin
a[i]:=a[i]*2;
write(a[i])
end;
s:=0;
for i:=1 to n do
s:=s+a[i];
f:=s+/n;
writeln(f)
end.

+ 0 -
EzikEzik
10 окт. 2014 г., 9:53:15 (9 лет назад)

var
   A:array [1..5] of integer;
   i,min,s:integer;
begin
   for i:= 1 to 5 do
   begin
      write('Введите ',i,' элемент массива: ');
      readln(A[i]);
   end;
   min:=A[1];
   s:=0;
   write('Введенный массив: ');
   for i:= 1 to 5 do
   begin
      write(A[i]:4);
      if A[i]<min then min:=A[i];
      s:=s+A[i];
      A[i]:=A[i]*2;
  end;
  writeln;
  writeln('Минимальный элемент массива = ',min);
  write('Удвоенные значиния элементов массива: ');
  for i:= 1 to 5 do write(A[i]:4);
  writeln;
  writeln('Среднее арифметическое элементов массива = ',s/5);
  end.

Ответить

Другие вопросы из категории

Возраст Бори и его компьютера в сумме составляет 10 лет. Если Борин компьютер проживет еще 3 года, то по окончании этого срока возраст Бори и его

компьютера в сумме составит … Выберите один ответ: 13 лет 7 лет 16 лет 20 лет 10 лет

Алфавит

некоторого языка содержит 32 буквы, 10 цифр и 22 знака препинания. Определите
вес одного символа

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА СОСТАВИТЬ ПРОГРАММУ!!!!(в паскале)

Ввести с клавиатуры массив А из 5 элементов, найти минимальное из них

У Пети дома есть несколько компьютеров, каждый из которых имеет в своем составе системный блок, монитор и клавиатуру. Если все системные блоки,

мониторы и клавиатуру собрать вместе, то все элементы, кроме двух, будут системными блоками, все элементы, кроме двух - клавиатурами, все элементы, кроме двух, будут мониторами
Сколько компьютеров у Пети дома? Помогите, пожалуйста, решить эту задачу.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.



Вы находитесь на странице вопроса "1)ввести с клавиатуры массив А из 5 элементов, найти минимальное из них 2)умножить все элементы массива А на 2 3)найти среднее", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.