Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL! ПОЖАЛУЙСТА!

10-11 класс

Дан массив X(N,M). Если первый элемент массива положительный, то найти сумму элементов среди элементов четных строк массива, иначе произведение.

Mariladnaya 19 дек. 2014 г., 23:27:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anna2001kit
20 дек. 2014 г., 0:36:17 (9 лет назад)

123456789101112k:=0;s:=1;if a[1]>0 then begin     for i:=1 to  n do            k:=k+a[i];     write('Сумма элементов равна ',k);endelse if a[1]<0 then begin    for i:=1 to n do        s:=s*a[i];    write('Произведение элементов равна ',s);end;

Ответить

Другие вопросы из категории

Перевести десятичные дроби в двоичную и восьмеричную системы счисления, оставив пять знаков в дробной части нового числа:

а) 21,5 б)432,54 в)678,333
Нужен не просто ответ, а, желательно, объяснение

паскаль. . . . . . . .ь. . . . . . . ..
Задача. Коля, Вася и Серёжа гостили летом у бабушки. Однажды один из мальчиков нечаянно разбил любимую бабушкину вазу. На вопрос, кто разбил вазу,

они дали такие ответы: Серёжа: 1) Я не разбивал. 2) Вася не разбивал. Вася: 3) Серёжа не разбивал. 4) Вазу разбил Коля. Коля: 5) Я не разбивал. 6) Вазу разбил Серёжа. Бабушка знала, что один из её внуков (правдивый), оба раза сказал правду; второй (шутник) оба раза сказал неправду; третий (хитрец) один раз сказал правду, а другой раз - неправду. Назовите имена правдивого, шутника и хитреца. Кто из внуков разбил вазу?

Решение нужно через таблицу истинности.

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

Помогите написать программу в pascal


Вы находитесь на странице вопроса "ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL! ПОЖАЛУЙСТА!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.