Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Построить машину тьюринга которая во входном слове все буквы И меняет на Е

10-11 класс

Lewandowski921 25 апр. 2015 г., 16:43:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DOMASHOV007
25 апр. 2015 г., 18:23:58 (9 лет назад)

var a: string;
    i: integer;
begin
     readln(a);
     for i := 0 to length(a) do
         if (a[i] = 'и') then a[i] := 'е';
     writeln(a);
end.

Это на Pascal'е =)

Ответить

Другие вопросы из категории

Помогите пожалуйста

1. определить размеры моноаудиофайлов с глубиной кодирования и частотой дискретизации: 16 бит и 8 кГц; 16 бит и 24 кГц.

2.Рассчитайте время звучания моно звука, если при 16-битном кодировании и частоте дискретизации 32 кГц его объем равен: 700 Кбайт; 6300 Кбайт

Необходимо отгадать слово, состоящее из 5 букв и записанное с помощью алфавита из 32 букв. Можно задавать вопросы ответом на которые будет "да" или

"нет". С помощью какого числа вопросов можно отгадать слово при оптимальной стратегии игры?

Читайте также

составить программу для машины Тьюринга:

1)которая добавляет к слову из единиц две единицы слева;
2)которая сдвигает слово из единиц на две единицы вправо;
3)которая переводит слово муха в слово слон, а остальные слова удаляет.

Сомнения!! Напиши в окне все буквы русского алфавита, для которых истинны утверждения: В русской алфавитной цепочке эта буква идёт позже буквы Ф. В

русской алфавитной цепочке следующая буква после этой буквы - гласная. Я думаю, что это Щ... НО Зачем-то дано большое окно для написания! И смущает в вопросе "все буквы"

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Помогите, пожалуйста, решить задачу на программирование Паскаль: Четвероклассник Петя сложил из карточек с прописными буквами слово. Оставшиеся

карточки с буквами он убрал в ящик стола. Перед приходом из школы его брата Васи Петя
смешал карточки, из которых он составил слово.
Когда первоклассник Вася увидел на столе карточки с буквами, он попытался из них
составить свое слово.
Определите, какие карточки с буквами из Петиного набора не использовал Вася, если
известны слово, которое собрал Петя и слово, которое собрал Вася.
Ваша программа должна
 Запросить слово, которое собрал Петя;
 Запросить слово, которое собрал Вася;
 Найти и вывести на экран в любом порядке буквы, которые использовал Петя, но не использовал Вася или вывести на экран сообщение о том, что Вася использовал все карточки с буквами Пети.



Вы находитесь на странице вопроса "Построить машину тьюринга которая во входном слове все буквы И меняет на Е", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.