Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из

10-11 класс

чисел ai,. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. Если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

Clybnica 14 нояб. 2014 г., 9:55:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nejenceve
14 нояб. 2014 г., 12:25:01 (9 лет назад)

program asd;
uses crt;
var
i:integer;
a: array[1..9] of integer;
naibnum:integer;
naib:integer;
naim:integer;
naimnum:integer;
begin
writeln('Вводите цифры');
for i:=1 to 9 do
begin
readln(a[i]);

if i = 1 then naim:=a[i];
if i = 1 then naib:=a[i];
if a[i] < naim then
begin
naim:=a[i];
naimnum:=i;
end;

if a[i] > naib then
begin
naib:=a[i];
naibnum:=i;
end;
end;

writeln('Наименьшее:',naim, ' номер:', naimnum);
writeln('Наибольшее:',naib, ' номер:', naibnum);
end.

Ответить

Другие вопросы из категории

При передачи информации В ЭВМ с интерфейсом "Общая шина" ЦП чаще всего выступает в роли.

1) Устройства, передающего информацию

2) Исполнителя

3) Задатчика

4) Устройство, принимающего информацию

Введите с клавиатуры одномерный массив S(K), элементами которого являются положительные и отрицательные числа. Найдите среднее арифметическое значение

среди последних 9-ти элементов массива, максимум среди первых 5-ти элементов. Замените в массиве все элементы, которые больше найденного среднего арифметического - на максимум.

написать программу на языке паскаль

пользователя вводит числа с интервалом 0,1
у=3х*х+х-4 на отрезке от а до в

Читайте также

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите, пожалуйста, срочно

Нужно написать программу в паскале
Найти наименьшее общее кратное n натуральных чисел, используя алгоритм евклида.

Помогите срочно нужно написать программу в Паскале по ветвлениям)

Ввести последовательно возраст Антона,Бориса и Виктора. Определить,кто из них старше. Пример:
Возраст Антона: 15
Возраст Бориса: 17
Возраст Виктора: 16
Ответ: Борис старше всех.

Пример:
Возраст Антона: 17
Возраст Бориса: 17
Возраст Виктора: 16
Ответ: Антон и Борис старше Виктора.

Заранее спасибо большое)

НАРОД ПОМОГИТЕ ПОЖАЛУЙСТА.

Нужно написать программу про месяца в виде case!!!!



Вы находитесь на странице вопроса "Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.