Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите с задачей. я написала решение, но где-то ошибка видимо. подскажите где именно и ошиблась. Смоделировать работу автомата по продаже

10-11 класс

билетов. Пусть населенные пункты обозначены номерами 1, 2, 3, 4, 5, 6, 7, 8. Стоимость одного билета к конкретному пункту определена так:

22,k=1

35,k=2,3

50,k=4

72,k=5,6

97 во всех остальных случаях.

Сколько будут стоить m билетов к некоторому населенному пункту? Для решения задачи используйте алгоритмическую конструкцию "выбор" (case).

program z5;

var

r, m, n, s:integer;

begin

writeln('r=', r);

readln(r);

writeln('m=', m);

readln(m);

case r of

1:n:=22;

2,3:n:=35;

4:n:=50;

5,6:n:=72;

else n:=97;

end;

s:=m*n;

writeln('s=', s);

end.

Valeriya1307 03 янв. 2014 г., 22:33:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sasha14Astahova
04 янв. 2014 г., 0:46:57 (10 лет назад)

program z5;
 uses crt;
var
r, m, n, s:integer;
begin
writeln('введите населённый пункт');
readln(r);
writeln('введите кол-во билетов');
readln(m);
case r of
1:n:=22;
2,3:n:=35;
4:n:=50;
5,6:n:=72;
else n:=97;
end;
s:=m*n;
writeln('s=', s);
end.

 

 

вы выводите r перед тем как ввести его, то есть по умолчанию присваевается 0, а так всё правильно.

writeln('r=', r);

readln(r);

Ответить

Читайте также

1.Среди цифр четырехзначного числа есть четная. Накидал тут решение, но где-то ошибка, не могу

понять где

var
t,s,d,e,i: integer;
begin
for i:= 1000 to 9999 do
t:=i div 1000;
s:=(i div 100)mod 10 ;
d:=(i div 10) mod 10;
e:=i mod 10;
if ((t mod 2=0) or (s mod 2 =0) or (d mod 2 =0) or (e mod 2=0)) then writeln ('TRUE') else writeln ('FALSE');
end.

В общем, задача стоит такая - нарисовать таблицу, где будут выводить значения.

Текст такой, но где-то есть ошибка.

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

помогите плиииз=))) у меня есть программа но вней 2 ошибки нужно сделать с помощью динамического массива... // laba4_2.cpp : Defines the entry

point for the console application.
//

#include "stdafx.h"
#include "stdio.h"
//#include "math.h"

using namespace std;


int main ( )
{
float *a;
int i,n;
printf("n=");
scanf("%i",&n);
a=(float*)malloc(N*sizeof(float));
for( i=0; i<=n-1;i++ )
{
printf("a[%i]= ",i );
scanf("%i",&a[i]);
}
for (i=0; i<=N-1; i++)
{
if (a[i]<0)
{
printf("oshibka\n");
}
else
{
if (a[i]/2==0)
{
printf("chetnoe \n");
}
else
{
printf("nechetnoe\n");
}
}

}

return 1;
}

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:



Вы находитесь на странице вопроса "помогите с задачей. я написала решение, но где-то ошибка видимо. подскажите где именно и ошиблась. Смоделировать работу автомата по продаже", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.