Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Задан линейный массив С из N элементов. Подсчитайте произведение четных элементов массива. Составьте блок-схему и программу. Ребят

10-11 класс

ООООООООООчень срочно !!!!!

Virtusprof 31 янв. 2014 г., 2:22:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
9908730
31 янв. 2014 г., 3:12:02 (10 лет назад)

var c:array[1..100] of integer;
n,i,s:integer;
begin
write('n=');
read(n);
writeln('massiv:');
for i:=1 to n do
begin
readln(c[i]);
if (c[i] mod 2=0) then
s:=s+c[i];
end;
writeln('s=',s);
end.

Ответить

Другие вопросы из категории

Паскаль, хелп

Если писать программу без имени(program name;)
В каком случае это делать можно, а в каком нет Hpvm сейчас

1.Какие существуют основные философские концепции? 2.Какая, с вашей точки зрения, концепция является наиболее верной? 3.Благодаря развитию каких наук

понятие информации стало широко употребляемым? 4.В каких биологических науках активно используется понятие информации? 5.Что такое наследственная информация? 6.К какой философской концепции, на ваш взгляд, ближе употребление понятия информации в генетике? 7.Если под информацией понимать только то, что распространяется через книги, рукописи, произведения искусства, средства массовой информации, то к какой философской концепции её можно будет отнести?

Delphi 7 написать программу "Телевизор".То есть, экран телевизора, рядом пульт, при нажатии на кнопки пульта на телевизора

появляются разные картинки.( в среднем надо 5 каналов- то есть 5 кнопок задействовать на пульте.

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

матрицу10 на 10 заполнить случайными однозначными числами вывести на экран.

Наити:1.количество четных чисел элементов матрицы
2.количество нечетных чисел элементов матрицы
3.сумму чисел диагонали матрицы
4.максимальный элемент матрицы и его адрес.
Написать блок схему и программу



Вы находитесь на странице вопроса "Задан линейный массив С из N элементов. Подсчитайте произведение четных элементов массива. Составьте блок-схему и программу. Ребят", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.