Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найдите номер первой и последней запятой в предложении, которое вводится с клавиатуры. (Запятых может быть от 0 до бесконечности.. ) помогите,

10-11 класс

пожалуйста

TIMSHIK2014 03 июля 2013 г., 21:08:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Papulya
03 июля 2013 г., 23:08:21 (10 лет назад)

var a.t.i:integer; s:string;
begin
readln(s); a:=0;
for i:=1 ti length(s) do
if s[i]=',' then begin
inc(a); t:=i;
if a=1 then writeln('Первая: ',t); end;
writeln('Последняя: ',t);
readln;
end.

Ответить

Другие вопросы из категории

последовательность действий для того, чтобы показать выступление в театре

например
1 - снять помещение

Автомат

получает на вход два двузначных шестнадцатеричных числа. В этих числах все
цифры не превосходят цифру 6 (если в числе есть цифра больше 6, автомат
отказывается работать). По этим числам строится новое шестнадцатеричное число
по следующим правилам.

1.
Вычисляются два шестнадцатеричных числа – сумма старших разрядов полученных
чисел и сумма младших разрядов этих чисел.

2.
Полученные два шестнадцатеричных числа записываются друг за другом в порядке
возрастания (без разделителей).

Пример.
Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A.

Определите,
какое из предложенных чисел может быть результатом работы автомата.

1) 9F 2) 911 3) 42

Читайте также

Задача 7. Найти первый и последний элементы массива, кратные

числу 3.
Пример: массив 7 2 6 5 4 4 10 3 9
элементы, кратные 3 6 39
первый и последний из них 6 9

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.

По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. Программа получает на вход

целое число n и должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), на которое приходится данный день.



Вы находитесь на странице вопроса "Найдите номер первой и последней запятой в предложении, которое вводится с клавиатуры. (Запятых может быть от 0 до бесконечности.. ) помогите,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.