Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста!!!!! создать массив случайных чисел, распечатать его на экране в строчку, из массива удалить все элементы, больше "к" ввести с

10-11 класс

клавиатуры

Smonyansnezhan 30 окт. 2013 г., 13:00:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ANDREO96
30 окт. 2013 г., 13:38:42 (10 лет назад)

var
 k,i,j:integer;
 a:array[1..20]of integer;
begin
write('Исходный массив: ');
for i:=1 to 20 do
  begin
  a[i]:=random(10);
  write(a[i]:3);
  end;
writeln;
write('Введите число: ');
readln(k);
j:=1;
for i:=1 to 20 do
  if a[i]<=k then
    begin
    a[j]:=a[i];
    j:=j+1
    end;
for i:=j to 20 do a[i]:=0;  
write('Преобразованный массив: ');
for i:=1 to j-1 do write(a[i]:3);
end.

Ответить

Другие вопросы из категории

можно ли записать данную программу используя циклы While и Repeat?Если да то предложите свой вариант.

program 5;
uses crt;
var i,n:integer ; x,y,s,p: real;
begin
x:=4.1; S:=0; P:=1;n:=10;
for i:=1 to n do
begin
s:= s+ ln(sqr(x)+I);
P:= p*(i+4*cos(x+I));
end;
Y:= s+p;
writeln('___x=',x:5:1,'___Y=',y:10:2);
writeln('___s=',s:5:3,'___P=',p:10:2);
end.

Товар стоит a руб. b коп. За него заплатили c руб. d коп. Сколько сдачи требуется получить? Вводятся 4 числа: a, b, c и d. Необходимо вывести 2 числа: e и

f, число рублей и копеек, соответственно. паскаль! помогите пожалуйста, дуб дубом в программировании((((

Помогите решить, пожалуйста!

Даны 6 различных чисел. Определить максимальное из них. (Определить функцию, находящую максимум из двух различных чисел).
Нужно написать программу для Pascal.

Помогите пожалуйста с 2 задачами! 1) Простым числом называется натуральное число p>1, натуральными делителями которого которого являются

только два числа: 1 и P. Определить, является ли введенное с клавиатуры число простым.

2) Дано число n. Верно ли, что это число содержит ровно 3 одинаковых цифры?

Читайте также

Информатика(Паскаль) помогите пожалуйста

Создать массив случайных чисел, вывести его на экран в строчку. Из массива удалить все элементы, принадлежащие заданному интервалу

помогите пожалуйста:

Создать массив случайных чисел (1-10), ввести с клавиатуры некоторое значение и определить номер элемента, равна этому значению, если таких элементов не существует, то вывести не существует.



Вы находитесь на странице вопроса "Помогите пожалуйста!!!!! создать массив случайных чисел, распечатать его на экране в строчку, из массива удалить все элементы, больше "к" ввести с", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.