Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10км. Каждый следующий день он увеличивал пробег

5-9 класс

на 10% от пробега предыдущего Определить:

COBRA233 14 сент. 2014 г., 23:12:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tarasenkomarkus
15 сент. 2014 г., 1:55:34 (9 лет назад)

program ncdkj;

uses crt;

var a,b,p,d,sd:integer;

begin

clrscr;

a:=10;

b:=10;

d:=1;

sd:=1;

p:=10*0,1;

repeat 

a:=a+p;

d:=d+1;

until a>20;

repeat 

b:=b+p;

sd:=sd+1;

s:=s+b;

until s>100;

case sd mod 7 of

0:writeln('сумма 100 км в 7');

1:writeln('сумма 100 км в 1');

2:writeln('сумма 100 км в 2'); И так до шести

case d mod 7 of

0:writeln('20 км в 7');

1:writeln('20 км в 1');

2:writeln('20 км в 2'); И так до шести

readln;

end.

Надеюсь второе  правильно понял, вроде должно работать

 

Ответить

Читайте также

Пожауйста помогите решить программу по информатике-Лыжник в первый день пробежал 10км каждый следующий день он увеличивал длинну на 10% от пред-го дня

.Определить в какой день он пробежит больше 20км ,а в какой день суммарный пробег за все дни превысит 100км?

написать программу,которая выводит на экран суммарный путь спортсмена за N дней тренировки.Если известно,что спортсмен,начав тренировку,в первый день

пробежал 5 км,каждый день он увеличивает дневную норму на 17% нормы предыдущего дня.ПОМОГИТЕ ПОЖАЛУЙСТА!!Желательно решение в 3 способах

написать программу,которая выводит на экран суммарный путь спортсмена за N дней тренировки.Если известно,что спортсмен,начав тренировку,в первый

день пробежал 5 км,каждый день он увеличивает дневную норму на 17% нормы предыдущего дня.ПОМОГИТЕ ПОЖАЛУЙСТА!!Желательно решение в 3 способах

Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?



Вы находитесь на странице вопроса "Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10км. Каждый следующий день он увеличивал пробег", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.