Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан целочисленный массив из 6-ти элементов.Поменять элементы местами по кругу(последний-первый)

10-11 класс

Asdf1978 08 сент. 2013 г., 11:00:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natavsiva
08 сент. 2013 г., 13:40:17 (10 лет назад)

const

n=6;

var

a:array [1..n] of integer;

k,i:integer;

begin

randomize;

for i:=1 to n do begin

a[i]:=random(30)+1;

write(a[i],' ');

end;

writeln; 

for i:=1 to 3 do begin

k:=a[i];

a[i]:=a[n+1-i];

a[n+1-i]:=k; 

end; 

for i:=1 to n do write(a[i],' '); 

readln;

end. 

Ответить

Другие вопросы из категории

Какие из

приведенных записей не могут быть путем к файлу?


А) D:\ Documents >\Films\Video.avi;

Пожалуйста помогите!

найти сумму 8+5 в двоичных кодах и произвести проверку

нужен конспект тема:

системное программное обеспечение!

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

1) Дан целочисленный массив из 30 элементов.

Элементы могут принимать значения от 160 до 200 ­– рост учащихся выпускного
класса. В баскетбольную команду берут тех, чей рост не менее 180 см. Опишите на
русском языке или на одном из языков программирования алгоритм, который подсчитывает
и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что
хотя бы один ученик играет в баскетбольной команде. Исходные данные объявлены
так, как показано ниже. Использовать другие переменные запрещается.



Вы находитесь на странице вопроса "Дан целочисленный массив из 6-ти элементов.Поменять элементы местами по кругу(последний-первый)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.