Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите пожалуйста написать программу по инфе..."Напишите программу получение из заданного целочисленного массива размером 30 элементов

5-9 класс

кол-во положительных, отрицательных и нулевых значений "

Jojoba1 19 апр. 2013 г., 11:41:13 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Artumka2005
19 апр. 2013 г., 12:29:14 (11 лет назад)

Const N = 30;
Var a:array [1..N] of integer; b,c,d,i:integer;
begin       
Writeln('Vvedite massiv');       
 for i:=1 to N do       
readln(a[i]);       
b:=0; c:=0; d:=0;       
for i:=1 to N do begin       
if a[i] = 0 then inc(b);       
if a[i] > 0 then inc(c);       
if a[i] < 0 then inc(d);       
end;       
writeln('Kol-vo ravnih 0 - ',b);       
writeln('Kol-vo bolshe 0 - ',c);       
writeln('Kol-vo menshe 0 - ',d);       
readln;
end.


+ 0 -
Таня291298
19 апр. 2013 г., 15:13:53 (11 лет назад)

Program Adelia17;
uses crt;
const n=30;
var
  matr:array [1..n] of integer;
  i,pos,neg,zero:integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
  writeln('Программа находит количество положительных, отрицательных и нулевых элементов массива');
  pos:=0; neg:=0; zero:=0;
  randomize;
  writeln('Массив: ');
  for i:=1 to n do
  begin
      matr[i]:=random(100)-50;
      write(matr[i]:4,' ');
      if matr[i]>0 then pos:=pos+1;
      if matr[i]<0 then neg:=neg+1;
      if matr[i]=0 then zero:=zero+1;
    end;
    writeln();
  writeln('Количество положительных элементов равно ',pos);
  writeln('Количество отрицательных элементов равно ',neg);
  writeln('Количество    нулевых    элементов равно ',zero);
end.

+ 0 -
Multilex
19 апр. 2013 г., 17:15:52 (11 лет назад)

5 минут

Ответить

Другие вопросы из категории

Сообщение, записанное при помощи 32-х символьного алфавита, содержит 80 символов, а сообщение, записанное с помощью 64-х символьного алфавита – 70

символов. Сравните объемы информации, содержащейся в этих сообщениях.



ПОЖАЛУЙСТА ЗАПИШИТЕ С ДАНО: ЗАРАНЕЕ СПАСИБО

Пожалуйста помогите решить задачу по информатике....учительница уже третью карточку дала,не могу решить....очень прошу.Сформируйте и выведите на экран

массив из девяти элементов каждые три последовательных элемента которого составлены по следующему правилу:1-й равен квадрату текущего индекса.2-й равен случайному числу 3-й равен полусумме двух предыдущих элементов.

Стереть символ слева от курсора можно клавишей

Shift : delete : back space : Enter

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите пожалуйста написать 2 программы

1)Написать программу которая меняет местами числа a и b(линейная и оператор присваивания)
2)Программа проверки существования треугольника по его 3 сторонам
Напишите пожалуйста***

Помогите, пожалуйста, написать программу в Паскаль

Напечатать таблицу перевода 1,2,…, 20 долларов США в рубли по текущему курсу (значение курса вводится с клавиатуры).

Помогите, пожалуйста, написать программу в Паскаль ABC.. Входящие данные - a,b,c - стороны треугольника. Найти:

a) Тип треугольника, который получается при построении по хаданным сторонам треугольника;



Вы находитесь на странице вопроса "помогите пожалуйста написать программу по инфе..."Напишите программу получение из заданного целочисленного массива размером 30 элементов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.