Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найдите и выведите на экран все трехзначные числа кратные 20, сумма цифр которых равна сумме цифр частного от деления их на 20. (Паскаль ABC)

5-9 класс

Напишите программу пожалуйста!

Nasta464 25 авг. 2013 г., 3:39:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
яна2602
25 авг. 2013 г., 5:52:09 (10 лет назад)

program chik;
var i,a,b,c:integer;
begin
for i:=100 to 999 do
begin
a:=i div 100;
b:=(i div 10)mod 10;
c:=i mod 10;
if(i mod 20=0)and(a+b+c=i div 20)then writeln(i);
end;
end.
ответ 180 т.к 
180 делится на 20
сумма цыфр 180 равно 1+8+0=9
180/20=9
9=9

+ 0 -
Pymba
25 авг. 2013 г., 7:52:05 (10 лет назад)

var i:integer;
function summa (n:integer):integer;
 var sum:integer;
 begin
  sum:=0;
  while (n<>0) do
   begin
     sum:=sum+(n mod 10);
     n:=n div 10;
   end;
  summa:=sum;
 end;
begin
  for i:=100 to 999 do
    if (summa(i)=summa(i div 20)) then writeln (i);
end.

+ 0 -
Madeline002
25 авг. 2013 г., 9:40:43 (10 лет назад)

а что значит сумма цифр которых равна сумме цифр частного от деления их на 20 пример напиши

Ответить

Другие вопросы из категории

Паскаль!!!!

1.

опишите компьютер будущего
Про­из­во­дит­ся двух­ка­наль­ная (сте­рео) зву­ко­за­пись с ча­сто­той дис­кре­ти­за­ции 64 кГц и 32-бит­ным раз­ре­ше­ни­ем, ре­зуль­та­ты

за­пи­сы­ва­ют­ся в файл, сжа­тие дан­ных не ис­поль­зу­ет­ся. Раз­мер файла с за­пи­сью не может пре­вы­шать 12 Мбайт. Какая из при­ведённых ниже ве­ли­чин наи­бо­лее близ­ка к мак­си­маль­но воз­мож­ной про­дол­жи­тель­но­сти за­пи­си?
1) 25 се­кунд
2) 37 се­кунд
3) 87 се­кунд
4) 98 се­кунд

Читайте также

Найдите выведите на экран все трехзначные числа,кратные 20,сумма цифр которых равны сумме цифр частного от деления их на 20 Может так

>

uses crt;
var b,c,d,t,i,s,k:integer; o:real;
begin
s:=0;
for k:=100 to 1000000000 do
begin
b:=k mod 10;
c:=k div 100;
d:=(k mod 100)div 10;
t:=d+b+c;
o:=(b div 20)+(c div 20)+(d div 20);
if ((k mod 20)=0) and (t=o) then s:=s+1;
end;
writeln('s=',s);
end.

1 вывести на экран все трехзначные числа кратные 50

2 найти количество четных чисел начиная с числа 20 до 60
3 найти сумму нечетных чисел от 100 до 150
паскаль

Помогите пожалуйста, срочно надо.

Заранее большое спасибо)
1) Определите и выведите на экран количество четырехзначных чисел, которые делятся без остатка одновременно на 5 и 11.
2) Найдите и выведите на экран все двузначные числа, у которых при умножения на 2 сумма цифр увеличивается на 5.

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .



Вы находитесь на странице вопроса "Найдите и выведите на экран все трехзначные числа кратные 20, сумма цифр которых равна сумме цифр частного от деления их на 20. (Паскаль ABC)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.