Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дан одномерный массив целых чисел размерностью 20.

10-11 класс

Определите количество положительных групп в этом массиве.
(группа это последовательность состоящая из 2-х и более положительных чисел находящихся рядом.)

Shestyklasnik 22 февр. 2014 г., 2:37:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angryshark
22 февр. 2014 г., 5:18:47 (10 лет назад)

Const  N=20;
Var  m:array[1..N]of real;
  i, group:byte;
  fl: boolean;
Begin
     for i := 1 to 20 do
     begin
         m[i] := random(20) - 10;
         writeln('[', i, '] => ', m[i]);
     end;

  group:=0;
 fl:=false;
  for i:=1 to N-1 do
    If (m[i]>0) and (m[i+1]>0) Then
fl:=true   
else
    if fl and (m[i+1]<=0) then
 begin
 inc(group);
 fl:=false
 end;
  if (fl) then inc(group);
  writeln(group);
End.

Ответить

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Дан одномерный массив целых чисел, заполненный

случайным образом числами из промежутка [-40, 30]. Массив данных хранится в
файле. Удалить из него все элементы, которые состоят из одинаковых цифр.
Результат записать в другой файл.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "Дан одномерный массив целых чисел размерностью 20.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.