Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить блок схему по программе на паскалеVar A:array[1..100] of integer;

10-11 класс

i,j,imax,n:byte;
Begin
j:=0;
write('Введите размер массива: ');readln(n);
For i:=1 to n do
Begin
readln(A[i]);
if (j=0)and(A[i]<0) then j:=i;
End;
writeln;
if j>0 then
Begin
if j<>n then imax:=j+1
else writeln('Первый отрицательный находится последним');
if imax<>0 then
For i:=imax+1 to n do
if A[i]>A[imax] then imax:=i;
if imax>0 then writeln('Max = ',A[imax]);
End
else writeln('Нету отрицательных');
readln;
End.

СаняЛ 28 дек. 2014 г., 8:11:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
20Olya03
28 дек. 2014 г., 11:00:14 (9 лет назад)

   ...................................................................

Ответить

Другие вопросы из категории

По данным x, y составить программу в Паскале для вычисления функции z:

1) z=(min(x, y)+0,5))/(1+max^2(x, y)).

2)z=система max(x, y), x<0
min(x, y), x>=0.

Номер 3: все кроме Г... Пожалуйста..
1) Вводится 4 числа. Вывести на экран наибольшую из первых цифр заданных чисел. Например, если a=46, b=831, c=2996, d=486, то напечатать число 8.

Использовать процедуру. - Написать на Паскале.

2) Дан массив A(10,5). Поменять местами элементы первого столбца с элементами столбца, в котором находится максимальный элемент массива. - Написать на Паскале.

3) Вводятся значения трех переменных. Переставить значения. Дополнительные переменные не использовать.
Составить алгоритм.

Читайте также

составить блок схему по программе pascal program zadacha 3_1. var max,x,e:real; begin writeln('введите натуральное число x');readln(x);

writeln('введите число y');readln(y); if x>y then max:=x else max:=y; writeln('большее из двух =',max); end.

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.

составьте блок-схему и программу для решения следующей задачи. Введите с клавиатуры два числа: к и л. Если они положительны, то замените каждое на квадрат

их суммы и выведите результаты на экран. Если все числа отрицательны, то каждое сделайте равным наименьшему и выведите результаты. Иначе, К приравняйте к 10, а Л - к 15 и выведите результаты

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.



Вы находитесь на странице вопроса "составить блок схему по программе на паскалеVar A:array[1..100] of integer;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.