Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Здравствуйте, помогите пожалуйста решить задание по информатике: дано вещественное число А. Используя операцию умножения получить А28 за шесть

10-11 класс

операций.Спасибо

Leovital 17 янв. 2017 г., 2:27:07 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yuliayulia01
17 янв. 2017 г., 3:11:38 (7 лет назад)

Program Anastas65;
var
 A,X,Y:integer;
begin
  write('Введите число A ');
  readln(A);
  writeln('***         Alphaeus         ***');
  writeln('*** Получение А^28 за 6 ходов ***');
  X := A*A; // получаем А^2
  Y := X*A; // получаем А^3
  X := X*X; // получаем А^4
  Y := Y*X; // получаем А^7
  Y := Y*Y; // получаем А^14
  Y := Y*Y; // получаем А^28
  writeln('    Результат = ',Y);
  writeln('**********************************');
end.

Ответить

Другие вопросы из категории

Составить алгоритм в виде блок-схемы.

На вход подаётся число. Нужно вывести числа от данного до 10. Если оно изначально больше 10, завершить программу.

КАКОЕ КОЛИЧЕСТВО ИНФОРМАЦИИ

НЕОБХОДИМО ДЛЯ КОДИРОВАНИЯ КАЖДОГО ИЗ 6500 ТЫС. 537 СИМВОЛОВ?

Читайте также

Помогите пожалуйста решить задание по информатике, срочно!

(х > 4) v ((х > 1) => ( х > 4))

Помогите, пожалуйста, решить задачу по информатике (с объяснениями): Задача 3. Экранная клавиатура КПК позволяет вводить символы русского

и английского алфавита прикосновением пера к экрану. Для переключения между заглавными и строчными буквами используется клавиша Shift, нажатие на которую приводит к смене режима на время ввода одной следующей буквы, и клавиша Caps Lock для постоянной смены режима. Для смены алфавита с русского языка на английский используется клавиша au (клавиша находится между Ctrl и Alt). В начальном состоянии клавиатура находится в режиме строчных русских букв.

Требуется написать программу, выводящую минимальную длину

последовательности прикосновений пера для набора заданной строки.

Технические требования.

Имя входного файла: INPUT.TXT

Имя выходного файла: OUTPUT.TXT

Формат входных данных:

В единственной строке входного файла содержится строка длиной не более 50 скатолов, содержащая заглавные и строчные русские и английские буквы. Формат выходных данных:

В единственной строке выходного файла содержится единственное число - минимальная длина последовательности прикосновений пера для набора заданной строки.

Примеры файлов входных данных: Примеры файлов выходных данных:

Строка 7

ПРИВЕТhеllо 14

Помогите, пожалуйста, решить задачу по информатике)

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду­щего элемента;
3-й-равен сумме двух предыдущих элементов.



Вы находитесь на странице вопроса "Здравствуйте, помогите пожалуйста решить задание по информатике: дано вещественное число А. Используя операцию умножения получить А28 за шесть", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.