Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найдите наименьшее число, большее 500, запись которого в шестнадцатеричной системе оканчивается на «42». Ответ запишите в десятичной

10-11 класс

системе счисления.

попро 11 апр. 2013 г., 12:55:19 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danya1661
11 апр. 2013 г., 14:55:05 (11 лет назад)

500_{10}=1F4_{16}
Ближайшее шестнадцатиричное число, имеющее на конце 42_{16} - это 242_{16}.
В десятичной системе счисления ему соответствует число 256*2+16*4+2
Оно равно 578_{10}.

Ответить

Другие вопросы из категории

1)Задан числовой массив из 10 элементов [5;150]Отсортировать массив по убыванию.

2)В комп. вводятся результ.экзаменов для 20 абитуриентов. Вывести на экран фамилии и результ. [10;30].Подсчитать их сред.ариф.
3)Дан массив из 10 элементов.Определить двухзначные числа кот. делятся на 4[10;100]

Формализуйте предостережение, которое одна жительница древних Афин сделала своему сыну, собиравшемуся заняться политической деятельностью: “Если ты

будешь говорить правду, то тебя возненавидят люди. Если ты будешь лгать, то тебя возненавидят боги. Но ты должен говорить правду или лгать. Значит, тебя возненавидят люди или возненавидят боги”.

Для кодирования некоторой последовательности, состоящей из букв А, Б, В,Г и Д, используется неравномерный двоичный код, позволяющий однозначнодекодировать

полученную двоичную последовательность. Вот этот код:А – 0; Б – 100; В – 1010; Г – 111; Д – 110. Требуется сократить для одной избукв длину кодового слова так, чтобы код по-прежнему можно былодекодировать однозначно. Коды остальных букв меняться не должны.Каким из указанных способов это можно сделать?

1)для буквы В – 101
2)это невозможно
3)для буквы В – 010
4)для буквы Б – 10 Пожалуйста объясните как решать, мне не просто переписать, мне надо понять как решать правильно.

Помогите,пожалуйста, составить блок-схему. Program Problem52_1; Type Bagaz = Record Kol:Byte; {Количество вещей} Ves:Real; {Вес в килограммах}

Sr_Ves_Bag:Real; {Средний вес вещи} End; Var Bagaz_Pas:Array[1..30] Of Bagaz; Flag:Boolean; N,i,Kol1,Kol2:Byte; Sr_Ves:Real; {Средний вес одной вещи всего багажа} Sr_Kol:Real; {Среднее количество вещей} Begin WriteLn('Задайте количество пассажиров:'); ReadLn(N); For i:=1 To N Do With Bagaz_Pas[i] Do Begin WriteLn('Пассажир N',i); Write('Количество вещей: '); ReadLn(Kol); Write('Общий вес: '); ReadLn(Ves); Sr_Ves_Bag:=Ves/Kol; {Средний вес вещи} WriteLn; {Пропуск пустой строки} End; Sr_Ves:=0; {Начальные значения} Sr_Kol:=0; {Нахождение среднего веса вещи всего багажа и} {среднего количества вещей} For i:=1 To N Do With Bagaz_Pas[i] Do Begin Sr_Ves:=Sr_Ves+Sr_Ves_Bag; Sr_Kol:= Sr_Kol+Kol; End; Sr_Ves:=Sr_Ves/N; Sr_Kol:=Sr_Kol/N; WriteLn('Задание а)'); Flag:=False; For i:=1 To N Do With Bagaz_Pas[i] Do If abs(Sr_Ves_Bag-Sr_Ves)<=0.3 Then Begin WriteLn('Кол-во вещей: ',Kol,' их вес: ',Ves); Flag:=True; End; If Not Flag Then WriteLn('Таких нет'); WriteLn('Задание б)'); Kol1:=0; {Кол-во пассажиров, имеющих более 2-х вещей} Kol2:=0; {Кол-во пассажиров, вещей у которых} {больше среднего} For i:=1 To N Do With Bagaz_Pas[i] Do Begin If Kol>2 Then Kol1:=Kol1+1; If Kol>Sr_Kol Then Kol2:=Kol2+1; End; WriteLn('Пассажиров, у которых больше 2-х вещей: ', Kol1); WriteLn('Пассажиров, у которых вещей большесреднего: ', Kol2); WriteLn('Задание в)'); Flag:=False; For i:=1 To N Do With Bagaz_Pas[i] Do If (Kol=1) and (Ves<30) Then Flag:=True; If Flag Then WriteLn('Такой пассажир имеется') Else WriteLn('Такого пассажира нет'); End.

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

№1. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 11 оканчивается на 1. №2.

Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 19 оканчивается на 4.

№3. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 27 оканчивается на 3.

Ребят помогите программу дописать по vba: в общем нужно сделать матрицу с рандомными числами, найти наименьшее число в ней, и сделать другую матрицу на

порядок меньше, с вычеркнутым столбцом и строкой на пересечении которых находится наименьшее число из первой матрицы. Я нашел наименьшее число, а как дольше делать понять не могу.
Вот начало самой программы:
Sub laba9()
Dim N As Integer, a() As Integer, i As Byte, j As Byte, min As Integer, l1 As Integer, l2 As Integer
N = Val(InputBox("Введите размерность массива"))
ReDim a(N, N)
Sheets("Лист1").Select
Sheets("Лист1").Range("A1:AAA100").Clear
For i = 1 To N
For j = 1 To N
a(i, j) = Rnd * 100
Cells(i, j) = a(i, j)
Next j
Next i
min = a(1, 1)
l1 = 1
l2 = 2
For i = 1 To N
For j = 1 To N
If a(i, j) < min Then
min = a(i, j)
l1 = i
l2 = j
End If
Next j
Next i
End sub

Найдите наименьшее K, такое что K! делится на N без остатка. K!=1*2*3...*(K-1)*K

Форма входа данных : в первой и единственной строке дано число N (1= Формат выходных данных: Выведите наименьшее число K факториал которого делится на N.

Примеры A.in = 4 A.out = 4 A.in = 8 A.out = 4

Найдите наименьшее K, такое что K! делится на N без остатка. K!=1*2*3...*(K-1)*K

Форма входа данных : в первой и единственной строке дано число N (1= Формат выходных данных: Выведите наименьшее число K факториал которого делится на N.

Примеры A.in = 4 A.out = 4 A.in = 8 A.out = 4



Вы находитесь на странице вопроса "Найдите наименьшее число, большее 500, запись которого в шестнадцатеричной системе оканчивается на «42». Ответ запишите в десятичной", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.