Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу и определить максимальное значение из пяти целых чисел!!!!!

5-9 класс

ПОМОГИТЕ ПОЖАЛУЙСТА!!!

СМАЙЛИ 12 сент. 2013 г., 0:37:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cleverest1
12 сент. 2013 г., 2:23:03 (10 лет назад)

{ Лаконично :) }
begin

  var a: array [1..5] of Int64;
  var i: byte;
  for i := 1 to 5 do readln(a[i]);
  writeln('Max: ', System.Math.Max(a[1], System.Math.Max(a[2], System.Math.Max(a[3],             System.Math.Max(a[4], a[5])))));
end.

+ 0 -
индусик
12 сент. 2013 г., 3:37:31 (10 лет назад)

procedure maximum(a,b:integer; var max:integer);
begin
if a>b then max:=a
else max:=b;
end;
var x,y,z,q,w,max:integer;
begin
writeln ('Введи 5 чисел');
Readln (x,y,z,q,w);
maximum(x,y,max);
maximum(max,z,max);
maximum(max,q,max);
maximum (max,w,max);
writeln (max);
end.

Ответить

Другие вопросы из категории

Перезалив. Решите пожалуйста. Тема: ,,Excel, Работа с формулами" Сделал бы сам да нет времяни. Т.к тут нельзя вставить Еxсel таблицу,

сделайте скриншоты с выполненным заданием, либо откройте Paint и просто отредактируйте моё изображение. Заранее спасибо.

Задание 2. Работа с формулами

Переведите 16 бит

В байты

Читайте также

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"



Вы находитесь на странице вопроса "Написать программу и определить максимальное значение из пяти целых чисел!!!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.