Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

5-9 класс

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

раоп 18 июля 2013 г., 23:10:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
айду
19 июля 2013 г., 0:36:49 (10 лет назад)

1.

program asd;
uses crt;
var
a: array[1..10] of integer;
i:integer;
sum:integer;
begin
writeln('Введите 10 цифр по очереди');
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i]>7) then begin a[i]:=7; sum:=sum+1; end;
end;

writeln(' ',sum);

end.

 

2. смысл задания? 10/2=5 или индексами ты имела ввиду значениями? 

3.
program asd;
uses crt;
var
a: array[1..10] of integer;
i:integer;
naib:integer;
begin
writeln('Введите 10 цифр по очереди');
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i]>naib) then naib:=a[i];
end;

writeln(' ',naib);

end.

Ответить

Другие вопросы из категории

СРОЧНО!!!!!!!! на интервале [-5;2] с шагом 0,5 построить таблицу значений и график функции у=1,5х3+4

сделать в microsoft exel (желательно скинуть файлом, но можно и инструкцией)

Управление передвигающимся в пространстве роботом осуществляется порадиоканалу с помощью команд, каждая из которых состоит из двух

частей:<направление> и <перемещение>.Возможны 6 направлений: вверх, вниз, вправо, влево, вперёд и назад.Перемещение задается натуральным числом, не превосходящим 54.В каждой команде направление кодируется минимально возможнымколичеством бит, одинаковым для каждого направления. Перемещение такжекодируется минимально возможным количеством бит, одинаковым длякаждого перемещения.Каков информационный объём последовательности из 40 команд?
1) 40 байт 2) 360 бит 3) 1620 байт 4) 2400 бит

мне нужно придумать алгаритм

Читайте также

1) Дан одномерный массив из 12 элементов. Составить программу заполняющую массив целыми числами в интервале -20 до 15 2)Требуется

подсчитать кол-во пятерок , четверок, тоек полученных за контрольную работу, если число учеников равно 8

3)Дан одномерный числовой массив,изменить знак элементов массива К[1;12] на противоположный

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.



Вы находитесь на странице вопроса "решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.