Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

очень срочно Требовалось

10-11 класс

написать программу, которая вводит с клавиатуры координаты точки на плоскости
(x, y – действительные числа) и определяет принадлежность точки заштрихованной
области, включая ее границы. Программист торопился и написал программу
неправильно. Вот она:

Aleshaalistratov 09 мая 2014 г., 4:20:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Erikashinohara
09 мая 2014 г., 7:10:39 (10 лет назад)

Рисунка нету, так что предположу, что в программе верное условие.
---
var x,y:real;
begin
     readln(x, y);
     if (x>=0) and (y<=1)
     and (x*x + y*y <= 1)
     and (y >= x-1) then
         write('принадлежит')
     else write('не принадлежит'

Ответить

Другие вопросы из категории

Составить блок-схему и написать программу для решения задачи. Организовать вычисление значения функции y по формуле y=4x+3/x-1 -√2x+9 для любого заданного

значения аргумента x. Учесть вывод сообщения о невозможности вычисления значения функции

помогитееее!!!! пожалуйста!!!!!

Читайте также

ребят очень срочно помогите ;(
Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно



Вы находитесь на странице вопроса "очень срочно Требовалось", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.