Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Вам дано одно предложение на англиском языке. Нужно найти все цифры, которые встречаются в этом предложений хотя бы один раз, в возрстающем порядке

5-9 класс

Timsaysa 24 апр. 2013 г., 9:15:40 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Semenova1999
24 апр. 2013 г., 11:21:30 (11 лет назад)

var mas:array[0..9] of integer;
 i:integer; 
 s:string;
begin
for i:=0 to 9 do
 mas[i]:=0;
readln(s);
 for i:= 1 to length(s) do 
 begin 
if s[i]='0' then mas[0]:=mas[0]+1;
  if s[i]='1' then mas[1]:=mas[1]+1; 
 if s[i]='2' then mas[2]:=mas[2]+1;
  if s[i]='3' then mas[3]:=mas[3]+1; 
 if s[i]='4' then mas[4]:=mas[4]+1; 
 if s[i]='5' then mas[5]:=mas[5]+1; 
 if s[i]='6' then mas[6]:=mas[6]+1; 
 if s[i]='7' then mas[7]:=mas[7]+1; 
 if s[i]='8' then mas[8]:=mas[8]+1; 
 if s[i]='9' then mas[9]:=mas[9]+1 
 end; 
for i:= 255 downto 1 do 
begin 
 if mas[0]=i then writeln(0); 
 if mas[1]=i then writeln(1); 
 if mas[2]=i then writeln(2); 
 if mas[3]=i then writeln(3); 
 if mas[4]=i then writeln(4); 
 if mas[5]=i then writeln(5); 
 if mas[6]=i then writeln(6); 
 if mas[7]=i then writeln(7); 
if mas[8]=i then writeln(8); 
if mas[9]=i then writeln(9) 
 end; 
 end.

Ответить

Другие вопросы из категории

ПРОВЕРЬТЕ, ПОЖАЛУЙСТА! МАССИВЫ, ПАСКАЛЬ.

УСЛОВИЕ: Задать случайным образом 10 элементов массива: целые числа из интервала от -5 до 50. Найти:
1) сумму нечётных элементов;
___________________________________________
Program Massivsumma;
var
a : array[-5..50] of integer;
n : integer;
summa : integer;
begin
randomize;
Write ('n='); Readln (n);
summa:=0;
for n:= 1 to 10 do
begin
write ('введите число'); readln (a[n]);
if a[n] mod 1 = 0 then summa:=summa+(a[n]);
writeln('сумма элементов с нечетными номерами: ',summa);
end;
end.

Дано четырехзначное число. Определить: какая цифра больше: вторая или последняя.

Сделать блок-схему и написать готовую программу.

Читайте также

Когда мы переписываемся, мы часто

используем цифры в нашем тексте. Вам дано одно предложение на английском языке.
Нужно найти все цифры, которые встречаются в этом предложений хотя бы один раз.

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 0 до 100 – баллы, полученные на ЕГЭ. Опишите на русском языке или

на одном из языков программирования алгоритм, который подсчитывает и выводит средний балл учащихся, сдавших экзамен (получивших оценку более 20 баллов). Гарантируется, что хотя бы один ученик в классе успешно сдал экзамен.

решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe

1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут.
На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных.

2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b.
Пример

Входные данные
Выходные данные
12
Hello world!
0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.
На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю не превосходящие 30000. Выдайте два искомых числа в порядке неубывания.
6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве.

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 160 до 200 ­– рост учащихся выпускного класса. В баскетбольную команду бе

рут тех, чей рост не менее 180 см. Опишите на русском языке или на одном из языков программирования алгоритм, который подсчитывает и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что хотя бы один ученик играет в баскетбольной команде.Нужно паскаль



Вы находитесь на странице вопроса "Вам дано одно предложение на англиском языке. Нужно найти все цифры, которые встречаются в этом предложений хотя бы один раз, в возрстающем порядке", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.