Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите))С клавиатуры вводится целое 4-х значное число.

5-9 класс

Выдать сообщение о том, есть ли в этом числе четные цифры и указать их
количество.
НА ПАСКАЛЕ

Aomine99 08 янв. 2015 г., 2:54:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kakto13tak
08 янв. 2015 г., 5:34:07 (9 лет назад)

 var b:integer;
begin
readln(b);
 If (b div 1000)mod 2=0 then writeln('1 цифра четная')
else writeln('1 цифра нечетная');
If ((b div 100) mod 10)mod 2=0 then writeln('2 цифра четная')
else writeln('2 цифра нечетная');
If ((b div 10)mod 10)mod 2=0 then writeln('3 цифра четная')else writeln('3 цифра нечетная');
If (b mod 100)mod 2=0 then writeln('4 цифра четная')
else writeln('4 цифра нечетная');
end.

Ответить

Читайте также

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

Кто-нибудь кто хорошо разбирается в Pascal ABC,помогите,пожалуйста! 1.Нарисовать круг, разделённый на N одинаковых частей, окрашенных в разный цвет.

Количество частей N вводится с клавиатуры. 2.Нарисовать пирамиду из разноцветных прямоугольников.Количество прямоугольников вводится с клавиатуры. 3.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует) Вычислить произведение максимального и минимального числа. 4.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует). Известно, что среди первых двух чисел нуля нет. Найти сумму двух наибольших чисел. 5.С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует). Известно, что среди первых трех чисел нуля нет. Найти среднее арифметическое трёх наименьших чисел.

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

Помогите решить срочно пожалуйста

Задача в pascal Цикл с условием
Первая задача:
S=1+2+3+4+.....+
вторая задача:
С клавиатуры вводятся целые числа 0 на конце,средние значение положительных чисел.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.



Вы находитесь на странице вопроса "Помогите))С клавиатуры вводится целое 4-х значное число.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.