Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить программу в Pascal определяющую произведение всех отрицательных элементов двумерного массива (элементв массива вводится с клавиатуры)

10-11 класс

Vkoboy 18 июля 2013 г., 7:59:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Judgedlgx
18 июля 2013 г., 9:07:38 (10 лет назад)

var 
  a: array [1..100,1..100] of integer; 
  s, n, m , i, j: integer;
begin  s:= 1; 
  readln(n,m); 
  for i:= 1 to n do   
    for j:= 1 to m do begin     
      readln(a[i,j]);     
      if a[i,j]<0 then s:=s*a[i,j]   
    end; 
  writeln(s);
end.

Ответить

Другие вопросы из категории

Читайте также

Составить программу на языке Pascal

Дан одномерный массив, содержащий m элементов. Что больше: абсолютная величина произведения всех отрицательных элементов данного массива или сумма его положительных элементов?

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Составить программу в PASCAL.

Ввести размерность матрицы и значения ее элементов.
Определить максимальный и минимальный элемент. Переставить их местами.
Найти среднее арифметическое отрицательных элементов в i-ой строке.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию



Вы находитесь на странице вопроса "Составить программу в Pascal определяющую произведение всех отрицательных элементов двумерного массива (элементв массива вводится с клавиатуры)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.