Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Пожалуйста,помогите мне с информатикой.Это задание решает,что у меня будет в аттестате.Все 4 и 5,а по инф. может выйти 3.Помогите решить,пожалуйста:

5-9 класс

Сформулируйте и выведите на экран массив из девяти элементов,каждые три составлены по следующему правилу:1й равен трехзначному числу;2й равен текущему индексу,увеличенному в 10раз;3й равен сумме двух предыдущих элементов.

Daryasereda 07 нояб. 2014 г., 14:13:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Екатерина435252
07 нояб. 2014 г., 16:44:52 (9 лет назад)

Program num1;
Uses crt;
Var
a :array [1..9] of integer;
i : integer;
Begin
clrscr;
writeln('Vvedite trexzna4nie 4isla: ');
write('a[1]=');readln(a[1]);
write('a[4]=');readln(a[4]);
write('a[7]=');readln(a[7]);
if (a[1]<100) or (a[1]>999) then writeln ('error')
else
if (a[4]<100) or (a[4]>999) then writeln('error') else
if (a[7]<100) or (a[7]>999) then writeln('error') else
begin
for i:=1 to 9 do
begin
if (i=2) or (i=5) or (i=8) then a[i]:=i*10;
if (i=3) or (i=6) or (i=9) then a[i]:=a[i-1]+a[i-2];
end;
writeln('Mas:');
for i:=1 to 9 do
write(a[i],' ');
end;
End.

+ 0 -
Gimbarr1232
07 нояб. 2014 г., 17:38:39 (9 лет назад)

uses crt;
var
a:array [1..9] of integer;
i,c:integer;
begin
clrscr;
randomize();
c:=1;
for i:=1 to 9 do
begin
if i=c then
begin
a[i]:=random(999-100)+1+100;
c:=c+3;
end
else
begin
a[i]:=i*10;
if i mod 3=0 then a[i]:=a[i-1]+a[i-2];
end;
write(a[i],' ');
end;
readln();
end.

Ответить

Другие вопросы из категории

Помогите решить плиззз)))) Трехзначеное десятичное число оканчивается цифрой три. Если эту цифру переместить на первое с лева мосто в числе, то есть с

нее будет начинаться запись нового числа, то это новое число буде на единицу больше утроенного исходного числа. Найдите исходное число?

статья, набранная на компьютере, содержит 8 страниц, на каждой странице 40 строк, в каждой строке 64 символа. В одном из представлений Unicode каждый

символ кодируется 16 битами. Определите информационный объем статьи в этом варианте Unicode.

Прошу, помогите решить, пожалуйста:))

С клавиатуры вводятся 17 чисел. Найти произведение

положительных чисел не делящихся на 17. Сделать в Турбо Паскале, методом repeat...until

Напишите для паскаля,пожалуйста.

С клавиатуры вводятся 17 чисел. Найти произведение положительных чисел не делящихся на 17.

Читайте также

1)Информатика-это наука... 2)География-это наука... 3)Фонетика-это раздел науки о... 4)Ботаника-это раздел науки о... 5)Имя

существительное-это самостоятельная часть речи,...

6)Глагаол-это самостоятельная часть речи,...

7)Земледельцы-это люди,...

8)Животноводы-это люди,...

9)Тяжёлая промышленность-это...

10)Лёгкая ромышленность-это...

Ребята пожалуйста помогите решить задание для 6 класса по информатике.

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!



Вы находитесь на странице вопроса "Пожалуйста,помогите мне с информатикой.Это задание решает,что у меня будет в аттестате.Все 4 и 5,а по инф. может выйти 3.Помогите решить,пожалуйста:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.