Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Исправьте ошибки: а)IF 1<X<2 THEN X:=X+1; Y:=0;

5-9 класс

ELSE X:=0; Y:=Y+1;

б)IF 1<X AND X<2

THEN BEGIN X:=X+1; Y:=0;
ELSE X:=0;Y:=Y+1; END;

Составьте блок-схему и запишите правильный вариант

Dimsan8 03 нояб. 2016 г., 20:35:39 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olegbabanov
03 нояб. 2016 г., 21:42:11 (7 лет назад)

После исправления ошибок получим два одинаковых фрагмента для 1) и 2):

 

if (1<X) and (X<2) then
  begin
    X:=X+1; Y:=0;
  end
  else
  begin
    X:=0; Y:=Y+1;
  end;

 

Блок-схема - во вложении

 

+ 0 -
Als1983
04 нояб. 2016 г., 0:11:49 (7 лет назад)

1) IF (1<x) and (x<2)

THEN BEGIN x:=x+1; y:=0; END

ELSE BEGIN x:=0; y:=y+1; END

 

2)

IF (1<X) AND (X<2)

THEN BEGIN X:=X+1; Y:=0; END
ELSE BEGIN X:=0; Y:=Y+1; END;  

 

 

Блок схему сделаешь по этому принципу

 

пример 1)

Условие - (1<x) and (x<2)
Действие 1 - x:=x+1; y:=0;

Действие 2 - x:=0; y:=y+1;

 

Второй думаю сможешь сама.

 

Вопросы, недочеты в ЛС

  

Ответить

Другие вопросы из категории

Читайте также

С клавиатуры вводятся два натуральных числа N и K (0<N<=K<=200000). Требуется написать программу, которая находит сумму простых чисел,

расположенных между N и K(включая эти числа).
Пример входных данных: 2 5
Пример выходных данных: 10

Program Pr1;

uses crt;
var fl1,fl2:text;
i,n,v,a,b:integer;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
v:=0;
for i:=1 to 1000000 do begin
if i>=10 then begin
a:=i div 10;
b:=i mod 10;
if (a mod 2<>0) and (b mod 2<>0) then v:=v 1;
end
else if i mod 2<>0 then v:=v 1;
if v=n then break;
end;
rewrite(fl2);
writeln(fl2,v);
close(fl1);
close(fl2);
end.

ребят в этом алгоритме есть ошибка найдите её плз

Исправьте ошибки, ПОЖАЛУЙСТА!!!

Кузнец подковал лошадь. В каждой подкове 6 гвоздей. Владельцу было предложено два вида оплаты:
1) заплатить за все гвозди 50 рублей.
2) За 1 гвоздь - 1 коп., 2 гвоздь - 2 коп., и т.д. каждый раз в два раза больше чем за предыдущий гвоздь.
Владелец предпочёл второй вариант. Во сколько раз больше он заплатил?

Короче, вот программа, но она не работает.
Ошибки исправьте, пожалуйста.

Привет ребят!Помогите мне с блок-схемой(алгоритмом).Ума не приложу,что делать:( Сама задача: -- -3,если х<-3 у=<|

x, если -3=<x<0

-- 4x,если х>4

--

<| - это фигурная скобка

--

Отдаю все пкт,что у меня есть,мне не жалко:)

Блин,что никто не знает?(((

ИСПРАВЬТЕ ПОЖАЛУЙСТА ТАМ НА КАРТИНКЕ КРАССНЫМ ГДЕ НЕПРАВИЛЬНО

Program Primer;
var
m:real;
n:real;
begin
writeln('Введите данные:');
writeln('Число "m":');
readln(m);
writeln('Число "n":');
readln(n);
If (m mod n=0) then writeln('Частное=', m/n);
If (m mod n<>0) then writeln('НЕ ДЕЛИТЬСЯ');
End.



Вы находитесь на странице вопроса "Исправьте ошибки: а)IF 1&lt;X&lt;2 THEN X:=X+1; Y:=0;", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.