Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

в паскале abc помогите написать программу.

10-11 класс

Дано натуральное число N. С клавиатуры вводятся N дат рождения в
формате DD.MM.YYYY (например, 17.04.2014). Напечатать название месяца, в
котором больше всего дней рождений. Если таких месяцев несколько, то
напечатать название самого позднего из них.

Klyamaanya 28 июля 2013 г., 6:15:33 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Omisha
28 июля 2013 г., 8:29:24 (10 лет назад)

var
  i,n,k,max:integer;
  s:string;
  a:array[1..12]of integer;
  naz:array[1..12]of string;
begin
naz[1]:=('январь');
naz[2]:=('февраль');
naz[3]:=('март');
naz[4]:=('апрель');
naz[5]:=('май');
naz[6]:=('июнь');
naz[7]:=('июль');
naz[8]:=('август');
naz[9]:=('сентябрь');
naz[10]:=('октябрь');
naz[11]:=('ноябрь');
naz[12]:=('декабрь');
write('Введите число N: ');
readln(n);
for i:=1 to n do
  begin
  write('Введите дату: ');
  readln(s);
  s:=copy(s,4,2);
  k:=StrToInt(s);
  a[k]:=a[k]+1;
  end;
for i:=1 to 12 do
  begin
  if a[i]>=max then
    begin
    max:=a[i];
    n:=i;
    end;
  end;
writeln('Месяц с наибольшим количеством: ',naz[n]);
end.

Ответить

Другие вопросы из категории

Дали второе задание, исходя из этого:http://znanija.com/task/4120829

Нужно составить программу, которая так же выводит числа, только главное условие - чтоб выводимые числа делились и на 2, и на 3, и на 5
рабочая программа для вывода кратных 2,3 и 5:
Private Sub CommandButton1_Click()Dim i As IntegerDim n As Integern = InputBox("До какого числа выводить результат?")
Dim Massiv() As IntegerDim s As IntegerFor i = 0 To nIf (i Mod 2) = 0 Or (i Mod 3) = 0 Or (i Mod 5) = 0 ThenReDim Preserve Massiv(s)Massiv(s) = is = s + 1Range("A" & CStr(s)).SelectActiveCell.FormulaR1C1 = Massiv(s - 1)End IfNext
End Sub

Для изготовления различных изделий А и В используется три виде сырья. На производство единицы изделия А его требуется затратить первого вида - 8 кг,

второго вида - 7 кг, третьего вида - 4 кг. На производство единицы изделия В требуется затратить сырья первого вида - 3 кг, второго вида - 6 кг, третьего вида - 9 кг. Производство обеспечено сырьем первого вида в колличестве 864 кг, второго вида - 864 кг, третьего вида - 945 кг. Прибыль от реализации единицы готового изделия А составляет 2 тыс. руб, В - 3 тыс. руб. Составить план производства изделий А и В, обеспечивающий максимальную прибыль от их реализации.

определить число элементов массива, больших К. По заданному условию сформировать одномерный массив, вывести на печать и произвести операции по обрабо

тке полученных компонентов массива. Исходными данными являются одномерный массив, элементы которого задаются с помощью датчика случайных чисел от -50 до +50 и целое положительное число К

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!



Вы находитесь на странице вопроса "в паскале abc помогите написать программу.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.