Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу в Pascal ABC используя операторы цикла WHILE...DO и REPEAT...UNTIL:заменить последний элемент массива минимальным (размерность массива

10-11 класс

=10)

030504 16 марта 2014 г., 4:39:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mi28092002
16 марта 2014 г., 6:40:48 (10 лет назад)

Var
  A: array [1..10] of integer;
min,i:integer;
begin
i:=1
while i<11 do
begin
readln(A[i]);
i:=i+1;
end;
i:=1;
n:=A[1];
repeat
if min>A[i] then 
min:=A[i]
i:=i+1;
until I=10;
A[10]:=min;
end


Ответить

Другие вопросы из категории

Как в этой программе задать свой промежуток от m до n а не от 1 до n

program z;
var n,i,j,s,mx,imx:integer;
begin
repeat
write('n>0 n=');
readln(n);
until n>0;
mx:=1;
imx:=1;
for i:=1 to n do
begin
s:=0;
for j:=1 to i do
if i mod j=0 then s:=s+j;
if s>mx then
begin
mx:=s;
imx:=i
end;
end;
writeln('Максимальную сумму делителей имеет число ',imx,' сумма=',mx);
readln
end.

Дана непустая последовательность натуральных чисел, за которой следует 0. Составьте программу нахождения суммы чисел этой

последовательности.Запустите программу на выполнение...(ПО ПАСКАЛЮ..)

Читайте также

Написать программу в Pascal ABC чтобы полностью работала, которая ввод данных

в одномерный целочисленный массив осуществляет посредством цикла WHILE…DO, а вывод - REPEAT…UNTIL (в скобках указана размерность
массива).

Реализовать задачу на компьютере, используя операторы цикла

и вложенные операторы цикла. Составить блок схему.

Даны площади нескольких квадратов. Найти длину диагонали самого
большого из них.

Написать программу в Pascal, используя массивы.

Дано массив А[1..n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки
Желательно с обьяснением строк

Срочно! Написать программу на Pascal ABC. Массивы.

См. приложенные скрины.



Вы находитесь на странице вопроса "Написать программу в Pascal ABC используя операторы цикла WHILE...DO и REPEAT...UNTIL:заменить последний элемент массива минимальным (размерность массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.