Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ПАСКАЛЬ.

5-9 класс

Дано действительное число K вида nnn.ddd ( по 3 цифровых разряда в дробной и целой частях). Поменяйте местами дробную и целую часть числа и выведете полученное новое значение.
ПАСКАЛЬ.

Rinaf 11 апр. 2014 г., 13:25:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Вафля2002
11 апр. 2014 г., 14:54:22 (10 лет назад)

var
  a, b: real;
  ip, fp: integer;

begin
  Write('Введите число в формате nnn.nnn ->');
  Readln(a);
  ip := trunc(a);
  fp := trunc(1000 * (a - ip));
  b := fp + ip / 1000;
  writeln('Результат: ', b)
end.

Тестовое решение:
Введите число в формате nnn.nnn ->135.782
Результат: 782.135



Ответить

Другие вопросы из категории

1)Что такое цикл?

2)Привести примеры циклов ( не менее 3 примеров )
3)Когда используют цикл?

помогите решить задачу Наряд игрушечного медвежонка Гоши состоит из куртки и кепки. У него есть три куртки - голубая, розовая и фиолетовая, а также две

кепки - золотистая и в горошек. Сколько различных нарядов можно составить для Гоши?

у исполнителя Калькулятор две команды, которым присвоены номера:

1.умножь на 3
2.вычти 4
Первая из них утраивает число на экране, вторая уменьшает его на 4.
Составьте алгоритм получения из числа 5 числа 17, соденржащие не более 5 команд.
(Например,21221-это алгоритм
вычти 4
умножь на 3
вычти 4
вычти 4
умножь на 3
который реобразует число 10 в 30.)
Если таких алгоритмов более одного, то запишите любой из них.

Каждый ученик в классе изучает по крайней мере один из двух языков: английский или французский. Английский язык изучают 25 человек, французский - 27

человек, оба языка 18 человек.

Сколько учеников:

1) изучают только английский?

2) изучают только французский?

3) сколько учеников в классе?

Помогите пожалуйста!!

Составить блок схему и программу , которая 10 раз выводит на экран ваши имя и фамилию.

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Паскаль, в его первоначальном виде, представляет собою чисто процедурный язык.

Простейшая программа на Паскале будет выглядеть следующим образом:
program upr;
begin
writeln ( ? ); {оператор вывода строки}
end.
Определи, какая фраза пропущена на месте вопросительного знака?
’Hello, World!’
“Lorem ipsum”
Just Another Perl Hacker

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

ПРОГРАММИРОВАНИЕ,ПАСКАЛЬ.РЕБЯТА,УМОЛЯЮ,ПОМОГИТЕ.

Задали написать программу на язвке паскаль:вычислить и вывести на экран 8 первых элементов ряда если каждый элемент задан формулой а1= i/sin*i



Вы находитесь на странице вопроса "ПАСКАЛЬ.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.