Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Определить сумму наибольшего и второго по

10-11 класс

значению наименьшего элементов. Паскаль. Не через массивы.
У меня во внешнем файле есть последовательность из отрицательных и положительных чисел!
1, 2,-3, 4, 5, -6, 7, 8, -9, 10!
Наибольшее число 10, наименьшее число -9, второе по значению наименьшее -6! Я нашел наименьшее и наибольшее, но не пойму как найти второе по значению наименьшее, помогите)

Belyaschckina 17 сент. 2014 г., 0:52:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dubrovin03
17 сент. 2014 г., 1:31:36 (9 лет назад)

var
    max, min, prev_min, n: integer;

begin
    max := -10000;
    min := 10000;
    prev_min := 10000;
    repeat
        read(n);
        if n > max then begin
            max := n;
        end;
        if n < min then begin
            prev_min := min;
            min := n;
        end;
    until n = 0;
   
    writeln(max, ' ', prev_min);
end.

+ 0 -
гаврило
17 сент. 2014 г., 4:14:22 (9 лет назад)

создай tmp с дубликатом последовательности, в котором наименьшее будет заменено на наибольшее и в новой последовательности наименьшее окажется вторым по значению наименьшим

+ 0 -
Flash12313212312
17 сент. 2014 г., 5:20:10 (9 лет назад)

спасибо, попробую

Ответить

Другие вопросы из категории

Дан массив А(100). Распечать наименьше значение попарных сумм. Решите, пожалуйста!!!

(С использованием команда random или без неё).

Помогите, пожалуйста. Паскаль

Написать программу, которая выводит целые числа в промежутке от 1 до 50, кратные четырем и считает их количество, сумму и произведение.

составить блок схему по программе pascal program zadacha 3_1. var max,x,e:real; begin writeln('введите натуральное число x');readln(x);

writeln('введите число y');readln(y); if x>y then max:=x else max:=y; writeln('большее из двух =',max); end.

1)Сначала суток прошло n секунд, определить: сколько полных часов прошло с начала суток, сколько полных минут прошло с начала текущего часа, сколько

полных секунд прошло сначала текущей минуты.
2)Производительность труда при выполнении некоторой работы повысилась на 40%. На сколько процентов сократилось время необходимое для выполнения этой работы.
3)Велосипедист должен попасть в место назначения к определённому сроку. Известно, что если он поедет со скоростью 15 км в час, то приедет на час раньше, а если скорость будет 10 км в час, то опоздает на 1 час. С какой скоростью должен ехать велосипедист, чтобы приехать вовремя?
решите в паскале без описания

Читайте также

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "Определить сумму наибольшего и второго по", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.