Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

алгоритм должен выводить 0, если нельзя построить треугольник с длинами сторон a,b,c (a,b,c-заданные числа), иначе 3,2,1 если треугольник

10-11 класс

соответственно, равносторонний или равнобедренный или другой.

Митяюшка 15 авг. 2013 г., 9:32:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dascha391
15 авг. 2013 г., 10:02:39 (10 лет назад)


Program Vlad971997;
uses crt;
var
  a,b,c:real;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  write('Введите a '); readln(a);
  write('Введите b '); readln(b);
  write('Введите c '); readln(c);
  if (a>=b+c) or (b>=a+c) or (a>=b+c) then
      writeln('Ответ "0": Со сторонами a,b,c нельзя построить треугольник')
    else
      if (a=b)and (b=c) and (a=c) then
          writeln('Ответ "3": Со сторонами a,b,c можно построить равносторонний треугольник')
        else
          if (a<>b)and (b<>c) and (a<>c) then
              writeln('Ответ "1": Со сторонами a,b,c можно построить другой треугольник')
            else
              writeln('Ответ "2": Со сторонами a,b,c можно построить равнобедренный треугольник')
end.

 

Проверено - работает на Паскаль АВС

+ 0 -
Dashmol
15 авг. 2013 г., 12:38:29 (10 лет назад)

CLS

a:

INPUT a

IF a<=0 THEN GOTO a

b:

INPUT b

IF b<=0 THEN GOTO b

c:

INPUT c

IF c<=0 THEN GOTO c

IF a>=b+c OR b>=a+c OR c>=a+b THEN PRINT 0: END

IF a=b AND b=c AND c=a THEN PRINT "треугольник равноcторонний" END

IF a=b OR b=c OR c=a THEN PRINT "треугольник равнобедренный": ELSE PRIINT "другой"

END

Ответить

Другие вопросы из категории

Помогите решить

Вычислить значение логического выражения L при заданных значениях переменных
L=(not(A=1)) and ((a=b) or (a<0)), при A=0, B=1

решите информатику

техникум первый курс
срочно до завтра
если можно то фото с решением

Читайте также

Pascal ABC

Оператор case of и if then else:

Задача 1
Вводятся 3 числа. Можно
ли построить треугольник с такими сторонами? Если построить треугольник можно,
то определить, является ли он
равносторонним, равнобедренным или прямоугольным?

Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить, существует ли треугольник с длинами сторон x,y,z. Если

треугольник, то является ли он равносторонним? 2)Дан одномерный массив. Найти количество смен знака между соседними элементами массива. Программа -Паскаль.

Для вывода на экран произвольной символьной строки нужно в команде вывода записать эту строку в апострофах. Например, по команде вывод "ОТВЕТ"

на экран выведется слово ОТВЕТ.

Определите, какая задача решается по следующему алгоритму:

алг Задача-6
вещ X
нач ввод X
если Х < 0
то вывод "отрицательное число"
иначе вывод "положительное число"
кв
кон

создайте форму для проверки существования треугольника по заданным длинам сторон. в форме предусмотреть три ячейки для ввода длин а, в и с, ячейку с вариан

тами результата "треугольник существует" треугольник не существует". для существзвания треугольника необходимо, чтобы сумма длин любых двух сторон была больше длины третьей стороны. внутри функции ЕСЛИ используйте условие: И(а+в>с; а+с> в; в+с> а) . помогите пожалуйста не получается формулу вписать.. ( ms excel)

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.



Вы находитесь на странице вопроса "алгоритм должен выводить 0, если нельзя построить треугольник с длинами сторон a,b,c (a,b,c-заданные числа), иначе 3,2,1 если треугольник", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.