Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран этот же массив в

5-9 класс

прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

и

Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

пожалуйста)

котёнки 17 февр. 2017 г., 10:47:13 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Нургалеевская
17 февр. 2017 г., 13:37:16 (7 лет назад)

const nn=10;
var
a:array[1..nn] of integer;
i,n:integer;
begin
write('Введите количество элементов массива: ');
readln(n);
for i:=1 to n do readln(a[i]);
for i:=1 to n do write(a[i],' ');
writeln;
for i:=n downto 1 do write(a[i],' ');
end.

 

 

const nn=50;
var
a:array[1..nn] of integer;
i,n:integer;
begin
write('Введите количество элементов массива: ');
readln(n);
for i:=1 to n do readln(a[i]);
writeln;
for i:=1 to n do if i mod 2 =0 then write(a[i],' ');
end.

Ответить

Другие вопросы из категории

Решите в тетради задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных

чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

Паскаль.

Вывести на экран числа, кратные К из промежутка
[А,В]. А, В, К вводятся.

Нужно написать программу.

заданы величины x,y действительного типа. написать программу обмена значений величин.использовать вспомогательные величины нельзя.

Читайте также

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.



Вы находитесь на странице вопроса "Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран этот же массив в", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.