Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составьте программу на языке Паскаль. Дам 50 баллов

5-9 класс

Veronika4234333 18 дек. 2016 г., 1:08:01 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Арютка21
18 дек. 2016 г., 2:43:43 (7 лет назад)

const
  nm = 50;{максимальная длина массива}

var
  i, n, t: integer;
  a: array[1..nm] of integer;

begin
  Write('Введите количество элементов в массиве: ');
  Readln(n);
  Writeln('Введите элементы массива через пробел или Enter');
  for i := 1 to n do Read(a[i]);
  i := 1;
  while i < n - 1 do
  begin
    if (i + 3 <= n) then begin t := a[i]; a[i] := a[i + 3]; a[i + 3] := t end;
    t := a[i + 1]; a[i + 1] := a[i + 2]; a[i + 2] := t;
    i := i + 4
  end;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(a[i], ' ')
end.

Тестовое решение:
Введите количество элементов в массиве: 13
Введите элементы массива через пробел или Enter
1 2 3 4 5 6 7 8 9 0 1 2 3
Результирующий массив
4 3 2 1 8 7 6 5 2 1 0 9 3


+ 0 -
Dedf111chf
18 дек. 2016 г., 4:34:41 (7 лет назад)

Это Вы ЗАТРАТИТЕ 50 баллов. А дадите 25 и еще половину (+13) за лучший ответ, т.е. максимум 38.

+ 0 -
Den93
18 дек. 2016 г., 5:29:39 (7 лет назад)

Вопрос - операторы procedure и function изучали?

+ 0 -
Anuta96
18 дек. 2016 г., 6:34:35 (7 лет назад)

нет

+ 0 -
Nastyastolbova
18 дек. 2016 г., 7:21:15 (7 лет назад)

Т.е. процедуры не проходили. Это плохо.

Ответить

Другие вопросы из категории

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Составить программу на языке Паскаль

Вывести на экран таблицу соответствия между весом в фунтах и весом в кг для значений от 1 до 20 с шагом 1 фунт (1 фунт=400г)
Пример оформления результата:
1 фунт=0,4 кг
2 фунт=0,8 кг
....
20 фунт=8 кг



Вы находитесь на странице вопроса "Составьте программу на языке Паскаль. Дам 50 баллов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.