Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

программа на delphi

10-11 класс

Разработать програму суммы N чисел пока сумма не превысит значение M.

Cashokklimenko 29 марта 2017 г., 1:51:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annavital1
29 марта 2017 г., 4:30:07 (7 лет назад)

Не совсем понял смысл, но вот:
procedure TForm1.Button1Click(Sender: TObject);
var
  i, s: integer;
begin
  for i := 0 to (StrToInt(Edit1.Text) - 1) do
  begin
    if (s > StrToInt(Edit2.Text)) then break;
    s := s + StrToInt(Memo1.Lines[i]);
  end;
  Memo2.Text := IntToStr(s);
end;

Эта штука суммирует числа из Memo1 (числа в строках), пока количество суммируемых не превысит N, либо их сумма не превысит M, либо числа не кончатся

+ 0 -
Dima585787
29 марта 2017 г., 5:11:59 (7 лет назад)

Комментарий удален

+ 0 -
ЗлатуляЕгорова
29 марта 2017 г., 5:56:38 (7 лет назад)

числа в едит вывод в мемо. очень нужно живу без компа

+ 0 -
Olba01
29 марта 2017 г., 8:26:36 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

В санатории на берегу моря отдыхают отец О, мать М, сын С и две дочери Д1, Д2. До завтрака члены семьи часто купаются в море, причем известно, что

1) Если отец утром отправляется купаться, то с ним обязательно идут купаться мать и сын.
2) Если сын идет купаться, то его сестра Д1 отправляется вместе с ним.
3) Вторая дочь Д2 купается тогда и только тогда, когда купается мать
4) Каждое утро купается, по крайней мере, один из родителей.
Если в воскресенье утром купалась лишь одна из дочерей, то кто из членов семьи в это утро ходил на море?

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Помогите исправить ошибки Задание: составить программу на яз. Паскаль с использованием цикла с неизвестным числом повторений для вычислений значения

функции F(x)=sin(x)+tg(x) на отрезке [А, В] при изменении аргумента в точках хi = А+iН, где Н – шаг. А=1, В=2, Н=0,125.

Листинг программы:

Program Tabulir;

Var x, y: real;

Begin x:=1;

While x≤2 do begin

y:=sin(x)+tg(x);

writeln (x:9:1, y:16:3);

x:=x+0,125;

End.



Вы находитесь на странице вопроса "программа на delphi", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.