Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу вычисления N! (факториал числа N). Факториал вычисляется по формуле (см.

5-9 класс

рисунок).

Протестировать программу для N=0, N=2 N=4.

Ilgiz111 01 июня 2013 г., 2:43:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юлия2001Югина
01 июня 2013 г., 5:37:25 (10 лет назад)

var n,f,i: integer;
begin
readln(n);
if n<0 then exit;
f:=1;
for i:=1 to n do f:=i*f;
writeln(f);
end.

Ответить

Другие вопросы из категории

Разгадайте шараду. Первый слог -острокоченная вершина горы , второй-поток грязи и камней ,а вместе -наименьший логический элемент двумерного цифрового

изображения в растворой графике. Количество букв в названии этого элемента равно А(7) Б(6) В(5) Г(4) ПОМОГИТЕ СРОЧН)))

11001101 11100101 11110010 00100000 11110101 11110011 11100100 11100000 00100000 11100001 11100101 11100111 00100000 11100100 11101110 11100001

11110000 11100000 00101110 ПОМОГИТЕ ПЕРЕВЕСТИ В БУКВЫ УМОЛЯЮ! И ЕЩЁ 240- ЭТО КАКАЯ БУКВА?

Читайте также

Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). Программист торопился и

написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится пять ошибок:

k:=1;

f:=0;

while k<n do

f:=f*k;

k:=k+1

Написать программу Turpo pascal помогите пожалуйста что сможете!!! Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу

вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.

Определение факториала:

0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.

Другими словами n!- это произведение n натуральных чисел.

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).



Вы находитесь на странице вопроса "Написать программу вычисления N! (факториал числа N). Факториал вычисляется по формуле (см.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.