Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан одномерный

10-11 класс

целочисленный массив А, состоящий из
N элементов,
N -
заданное натуральное число. Упорядочить элементы массива
по неубыванию. (программа +блок-схема)на языке QBasic

Gomer1 06 июля 2013 г., 6:32:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КаринаСахипова
06 июля 2013 г., 8:03:10 (10 лет назад)

INPUT "n="; n
DIM a(n) AS INTEGER
RESTORE
FOR i = 1 TO n
    READ a(i)
NEXT i
FOR i = 1 TO n - 1
    mi = a(i): u = i
    FOR j = i TO n
        IF a(j) < mi THEN
            mi = a(j): u = j
        END IF
    NEXT j
    r = a(i): a(i) = mi: a(u) = r
NEXT i

Ответить

Другие вопросы из категории

Точка задана своими координатами. Определить, принадлежит ли точка заданной области (включая границу). Формат входных данных Во входном файле записаны два

вещественных числа - координаты точки . Формат выходных данных В выходной файл необходимо вывести или в зависимости от ответа на вопрос задачи.

Примеры: Вход -3 2 Выход Yes

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

№1 Дана действительная квадратная матрица порядка n. Найти произведение четных элементов.

№2 В данном одномерном массиве Х[1..n] найти сумму отрицательных элементов , кратных 7.

Дан одномерный массив целых чисел, заполненный

случайным образом числами из промежутка [-40, 30]. Массив данных хранится в
файле. Удалить из него все элементы, которые состоят из одинаковых цифр.
Результат записать в другой файл.

Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить, существует ли треугольник с длинами сторон x,y,z. Если

треугольник, то является ли он равносторонним? 2)Дан одномерный массив. Найти количество смен знака между соседними элементами массива. Программа -Паскаль.



Вы находитесь на странице вопроса "Дан одномерный", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.