Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

На­пи­ши­те

5-9 класс

про­грам­му, ко­то­рая в по­сле­до­ва­тель­но­сти на­ту­раль­ных чисел опре­де­ля­ет
сумму чисел, крат­ных 3. Про­грам­ма по­лу­ча­ет на вход ко­ли­че­ство чисел в
по­сле­до­ва­тель­но­сти, а затем сами числа. В по­сле­до­ва­тель­но­сти все­гда
име­ет­ся число, крат­ное 3. Ко­ли­че­ство чисел не пре­вы­ша­ет 100. Введённые
числа не пре­вы­ша­ют 300. Про­грам­ма долж­на вы­ве­сти одно
число — сумму чисел, крат­ных 3.

000p 05 нояб. 2016 г., 22:48:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
6бМаксим
06 нояб. 2016 г., 1:27:26 (7 лет назад)

var a,i,n,sum: integer;
begin
writeln('Введите количество чисел');
readln(n); sum:=0;
for i:=1 to n do begin
 writeln('Введите число');
 readln(a);
 if a mod 3=0 then sum:=sum+a;
end;
writeln('Сумма чисел кратных 3 равна ', sum);
readln
end. 

Ответить

Другие вопросы из категории

В таблице приведены запросы к поисковому серверу. Расположите номера

запросов в порядке возрастания количества страниц, которые найдет поисковый
сервер по каждому запросу. Для обозначения логической операции “ИЛИ” в
запросе используется символ |, а для логической операции “И” – &.
№ Запрос
1 телефон & NOKIA
2 телефон | смартфон | NOKIA
3 ( коммуникатор | смартфон ) & телефон & NOKIA

4 телефон & смартфон & NOKIA

В таблице приведены запросы к поисковому серверу. Расположите номера
запросов в порядке возрастания количества страниц, которые найдет поисковый
сервер по каждому запросу. Для обозначения логической операции “ИЛИ” в
запросе используется символ |, а для логической операции “И” – &.
№ Запрос
1 ( Майорка | Италия ) & отели & аквапарки
2 отели & Италия & аквапарки
3 отели & аквапарки

4 отели | Италия | аквапарки

На рисунке изображена схема дорог, связывающих города A, B, C, D, E, F, G, H,
K, L, P, M. По каждой дороге можно двигаться только в одном направлении,

указанном стрелкой. Сколько существует различных путей из города A в город M?

Читайте также

На­пи­ши­те про­грам­му, ко­то­рая в по­сле­до­ва­тель­но­сти на­ту­раль­ных чисел опре­де­ля­ет сумму чисел, окан­чи­ва­ю­щих­ся на 3. Про­грам­ма

по­лу­ча­ет на вход ко­ли­че­ство чисел в по­сле­до­ва­тель­но­сти, а затем сами числа. В по­сле­до­ва­тель­но­сти все­гда име­ет­ся число, окан­чи­ва­ю­ще­е­ся на 3. Ко­ли­че­ство чисел не пре­вы­ша­ет 100.

B 8 У ис­пол­ни­те­ля Квад­ра­тор две команды , которым присвоены номера : 1. вычти 1

2. возведи в квадрат Первая из них умень­ша­ет число на экра­не на 1, вто­рая воз­во­дит его во вто­рую сте­пень. Ис­пол­ни­тель ра­бо­та­ет толь­ко с на­ту­раль­ны­ми чис­ла­ми. Со­ставь­те ал­го­ритм по­лу­че­ния из числа 2 числа 64, со­дер­жа­щий не более 5 ко­манд. В от­ве­те за­пи­ши­те толь­ко но­ме­ра ко­манд. (На­при­мер, 11121 — это ал­го­ритм: вычти 1, вычти 1, вычти 1, воз­ве­ди в квад­рат, вычти 1, ко­то­рый пре­об­ра­зу­ет число 7 в 15.) Если таких ал­го­рит­мов более од­но­го, то за­пи­ши­те любой из них.

До­ступ к файлу com.txt, на­хо­дя­ще­му­ся на сер­ве­ре mail.net, осу­ществ­ля­ет­ся по про­то­ко­лу http. Фраг­мен­ты ад­ре­са файла

за­ко­ди­ро­ва­ны бук­ва­ми от А до Ж. За­пи­ши­те по­сле­до­ва­тель­ность этих букв, ко­ди­ру­ю­щую адрес ука­зан­но­го файла в сети Ин­тер­нет. А) /Б) httpВ) ://Г) .txtД) .netЕ) mailЖ) com

Ав­то­мат по­лу­ча­ет на вход два дву­знач­ных де­ся­тич­ных числа. По по­лу­чен­ным чис­лам стро­ит­ся новое де­ся­тич­ное число по сле­ду­ю­щим

пра­ви­лам.
1. Вы­чис­ля­ют­ся два числа — сумма цифр пер­во­го числа и сумма цифр вто­ро­го числа.
2. По­лу­чен­ные два числа за­пи­сы­ва­ют­ся друг за дру­гом в по­ряд­ке не­убы­ва­ния (без раз­де­ли­те­лей).

При­мер. Ис­ход­ные числа: 73 и 45. Сумма цифр пер­во­го числа: 10, сумма цифр вто­ро­го числа: 9. Ре­зуль­тат: 910.

Опре­де­ли­те, сколь­ко из при­ведённых ниже чисел могут по­лу­чить­ся в ре­зуль­та­те ра­бо­ты ав­то­ма­та:

211 1717 1817 1718 1719 219 21 10

В от­ве­те за­пи­ши­те толь­ко ко­ли­че­ство чисел.



Вы находитесь на странице вопроса "На­пи­ши­те", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.