Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан целочисленный массив из 30 элементов. Числа лежат в интервале от -500 до 500. Опишите на языке Паскаля алгоритм, который находит среднее

10-11 класс

арифметическое всех чисел, которые кратны первому элементу. Гарантируется, что первый элемент положительный.

SladostiMilost73 01 авг. 2013 г., 0:37:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olegarmashev
01 авг. 2013 г., 2:43:33 (10 лет назад)

var
  i, sum, n : integer;
  a : array [1..30] of integer;
begin
  sum := 0;
  n := 0;
  for i := 1 to 30 do read (a[i]);
  for i := 1 to 30 do
    if a[i] mod a[1] = 0 then
    begin
      n := n + 1;
      sum := sum + a[i];
    end;
  write (sum / n);
end.

Ответить

Другие вопросы из категории

1.

Чему равно количество бит информации в сообщении “Ваня на олимпиаде по
информатике занял одно из 8 мест”?

написать программу для решения следующей задачи. В двумерном массиве,

состоящем из целочисленных элементов, поменять местами в каждой строке
наибольший и первый не принадлежащий интервалу (a, b) элементы.
(паскаль)

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. С клавиатуры вводится целое число X. Опишите на

русском языке или на одном из языков программирования алгоритм, который находит и выводит наименьший номер элемента, равного X, или сообщение, что такого элемента нет.
const N=30;


var a: array [1..N] of integer;


i, j, x: integer;

СРОЧНО!!! Дан целочисленный массив из 30 элементов, все элементы которого – неотрицательные числа, не превосходящие 10000. Опишите на русском

языке или на одном из языков программирования алгоритм, который находит и выводит минимальное трехзначное число, записанное в этом массиве. если таких чисел нет, нужно вывести сообщение «Таких чисел нет».

объяните решение пожалуйста программу не обязательно писать

помогите пожалуйста.....................................в течении получаса. дан целочисленный массив из 30 элементов. элементы массива могут

принимать значения от 0 до 1000.описать на русском или на одном из языков програмирования алгоритм,который находит и выводит среднее арифметическое всех элементов массива,имеющих нечетное значение

1) Дан целочисленный массив из 30 элементов.

Элементы могут принимать значения от 160 до 200 ­– рост учащихся выпускного
класса. В баскетбольную команду берут тех, чей рост не менее 180 см. Опишите на
русском языке или на одном из языков программирования алгоритм, который подсчитывает
и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что
хотя бы один ученик играет в баскетбольной команде. Исходные данные объявлены
так, как показано ниже. Использовать другие переменные запрещается.



Вы находитесь на странице вопроса "Дан целочисленный массив из 30 элементов. Числа лежат в интервале от -500 до 500. Опишите на языке Паскаля алгоритм, который находит среднее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.