Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Решите пожалуйста.Срочно нужно Найти сумму элементов,стоящих на четных местах в массиве из 10 элементов,заданных с клавиатуры

10-11 класс

Ana2723 18 янв. 2017 г., 20:04:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelina160103
18 янв. 2017 г., 22:26:39 (7 лет назад)

var

a:array [1..10] of integer;

i,s:integer;

begin

s:=0; 

for i:=1 to 10 do begin

write ('A[',i,'] = ');readln(a[i]);

if i mod 2 = 0 then s:=s+a[i]; 

end;

writeln ('Summa: ',s);

readln;

end. 

Ответить

Другие вопросы из категории

HELP!ЗАДАНИЕ В ПАСКАЛЕ!!!!!!!! код проги рисующей параболу Var g,h:integer; x,y:real; x0,y0,xm,ym,Mx,My:integer; begin

g:=detect;

InitGraph(g,h,'');
begin

line(0,round(getmaxY/2),GetmaxX,round (GetMaxy/2));
line (round (GetMaxX/2),0,round(GetmaxX/2),GetmaxY);

end;


For xm:=20 to 620 do

Begin

x:=(xm-x0)/Mx;

y:=X*X;

ym:=round(y0-y*My);

PutPixel(xm,ym,15);

End;

Readln;

End.

что означает

Begin

x:=(xm-x0)/Mx;

y:=X*X;

ym:=round(y0-y*My); ? Зачем использовать его в коде?

__________

Mx, My-масштабы соответственно по осям x и y, которые показывают число пикселей в одной физической единице,

x, y- физические координаты точки,

xm, ym- машинные координаты точки,

x0, y0- машинные координаты начала физической системы координат.

Ребят, помогите с информатикой. Капец как надо...

заполните массив из 8 чисел натуральными числами с клавиатуры найти сумму первых четырех и произведение последних четырех поменять первый и четвертый элемент массива найти среднее арифметическое 3 - 7 вывести все на экран

Читайте также

Дана квадратная матрица размера N. Если сумма элементов по главной диагонали больше суммы элементов на побочной диагонали, то заменить элементы стоящие на

четных местах в строке на “ * ”, а элементы стоящие на нечетных местах в строке на ноль.

Задача Pascal

Найти наименьшие элементы в каждом столбце матрицы Х(5,5) и переписать их в одномерных массив А.В массиве А вычислить сумму элементов,стоящих на четных местах и произведение элементов,стоящих на нечетных местах.Массив А,сумму и произведение вывести на экран

Паскаль,помогите!!! В числовом массиве из 10 элементов, заданных случайным образом от -100 до 500. Найти: 1) сумму положительных элементов,

стоящих на чётных местах; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах;

составьте программу,которая запрашивает значение элементов одномерного массива A,состоящего из 10 элементов,формирует и выводит на экран в строку данный

массив.Найти сумму определённого элемента;количество элементов,стоящих на нечетных местах;произведение элементов,кратных 5.

Помогите срочно нужно программирование в паскале !! написать программу!!

1 ввести с клавиатуры последовательность из N чисел и найти максимальное число среди элементов стоящих на чётных местах.
2 Выяснить является ли натуральное число K степенью 3.



Вы находитесь на странице вопроса "Решите пожалуйста.Срочно нужно Найти сумму элементов,стоящих на четных местах в массиве из 10 элементов,заданных с клавиатуры", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.