Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить, очень нужно... 2. Составьте блок-схему алгоритма(её не надо) и программу вычисления в массиве A(10) количества положительных

10-11 класс

элементов.
3. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Makstm 19 апр. 2013 г., 15:22:45 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karibaev2003
19 апр. 2013 г., 17:11:41 (11 лет назад)

 2)

Program Massiv1;

var a:array[1..10] of real;

       i:integer;

       s:real;

begin

      clrscr;

       write('Введите элементы массива: ');

 

      s:=0;

 

      for i :=1 to 10 do

             begin

                  readln(a[i]);   

 

                  if  (a[i]>0) then s:=s+1;

 

           end;

writeln;

for i :=1 to 10 do     writeln(a[i]:3:3);   

 writeln('Количество положительных элементов:',s);

 readkey;

 

 end.

 

 

 3)

Program Massiv2;

var a:array[1..10] of integer;

       i,b:integer;  

  begin

       clrscr;

       b:=2; 

       for i :=1 to 10 do

             begin

                a[i]=i+b;

                 b:=b+1; 

 

                 write(a[i]:2); 

 

             end;   

readkey;

end.

 

 

 

 

 

Ответить

Читайте также

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10) количества положительных элементов.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.

Помогите пожалуйста! Составить блок-схему алгоритма решения задачи, условие которой выбирается из списка в соответствии с номером варианта. Оплата за

пользование электроэнергией производится по разным тарифам в зависимости от того, установлены ли в доме электрические или газовые плиты. В первом случае (электрические плиты) стоимость 1 кВт/час составляет 2 руб., во втором – 2.5 руб. Составить программу расчета суммы оплаты за пользование электроэнергией за месяц, если известен расход электроэнергии (количество потребленных в течение месяца кВт/час)

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.



Вы находитесь на странице вопроса "Помогите решить, очень нужно... 2. Составьте блок-схему алгоритма(её не надо) и программу вычисления в массиве A(10) количества положительных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.