Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста решить задачу №8 b) на pascal

10-11 класс

Franchyz87 11 окт. 2013 г., 11:48:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
мномном
11 окт. 2013 г., 13:43:27 (10 лет назад)

var
  n, i: integer;
  x, nf, p: double;

begin
  Write('Введите через пробел n и х: ');
  Readln(n, x);
  nf := 1;
  p := 1;
  for i := 1 to n do
  begin
    nf := nf * i;
    p := p * (1 + sin(i * x) / nf)
  end;
  Write(p)
end.

Тестовое решение:

Введите через пробел n и х: 5 1.7
1.50935987485702


+ 0 -
Zlatoslavapoly
11 окт. 2013 г., 16:26:42 (10 лет назад)

var n, b, i:integer;
      x, a, c, d:real;
begin
   writeln('Введите n и x в градусах');
   read (n, x);
   a:=1;
   b:=1;
   for i:=1 to n do
      begin
      b:=b*i;
      a:=a*(1+sin(i*x*2*pi/360)/b);
      end;
   writeln(a);
end.

+ 0 -
Ipoleg
11 окт. 2013 г., 19:06:19 (10 лет назад)

В чем измеряется x в радианах или градусах?

+ 0 -
Romavadik
11 окт. 2013 г., 21:50:46 (10 лет назад)

эм, не знаю, когда давали задачу ничего не сказали, наверное просто в водится с клавиатуры...

+ 0 -
Ляман
11 окт. 2013 г., 23:32:41 (10 лет назад)

хорошо тогда сделаю в градусах

+ 0 -
лизка89
12 окт. 2013 г., 0:08:10 (10 лет назад)

ок,спасибо

Ответить

Другие вопросы из категории

Читайте также

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Помогите, пожалуйста, решить задачу:

Дан вектор из 25 элементов. Найти минимальное значение. Записать на языке Pascal и построить алгоритм.

ПОМОГИТЕ ПОЖАЛУЙСТА РЕШИТЬ ЗАДАЧУ!! информационный объём дискеты 1,44 Мбайта. Достаточно ли одной дискеты,чтобы записать на неё 5

файлов,информационный объём каждого из которых примерно равен 300 Кбайт. Почему? Информационный объём файла примерно 1 000 000 байт. Архиватор сжимает его на 300%. Поместится ли оно на одну дискету, информационный объём которой 1,44 Мбайт? Почему? Выполнить вычисление 1101111011,01(2) - 101000010,0111(2)



Вы находитесь на странице вопроса "Помогите пожалуйста решить задачу №8 b) на pascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.