Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Исправьте ошибки пожалуйста Pascal!Линейные алгоритмы.Пара кроликов каждый год дает приплод двух (самку и самца) которые через 2 месяца способны давать

10-11 класс

новый приплод. Сколько кроликов будет через год

program uses crt{Пара кроликов каждый год дает приплод двух (самку и самца)кот.через 2месяца способны давать новый приплод.Ск-ко кроликов будет через год.}

var k : integer

function f(n:integer):integer

begin if n=0

then f=1

elsey if n=1

then f=2

elsey f=f(n-2)+f(n-1)

end

begin for k=10 to 12 do

writeln(f(k))

redln

end.

Barminanatalia4 02 мая 2014 г., 10:53:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashapavlo
02 мая 2014 г., 11:45:08 (10 лет назад)

uses crt;{Ïàðà êðîëèêîâ êàæäûé ãîä äàåò ïðèïëîä äâóõ (ñàìêó è ñàìöà)êîò.÷åðåç 2ìåñÿöà ñïîñîáíû äàâàòü íîâûé ïðèïëîä.Ñê-êî êðîëèêîâ áóäåò ÷åðåç ãîä.}
var k : integer;
function f(n:integer):integer;
begin if n=0
then f:=1
else if n=1
then f:=2
else f:=f(n-2)+f(n-1);
end;
begin for k:=10 to 12 do
writeln(f(k));
readln;
end.

вот если просто исправить ошибки

Ответить

Другие вопросы из категории

Помогите пожалуйста !!!! Очень надо !!!

1)Перевести двоичное число А в восьмеричную и шестнадцатеричную системы счисления.
А=10001001,1001
2)Перевести в десятичную систему счисления следующее двоичное число
1010101010
3)Перевести десятичное число А в g-e системы счисления.
А=493, g=5;12
4)Перевести десятичные числа в двоичные с точностью до 10\-8
0,2778

Написать программу в паскале

Дано три массива A,B,C состоящее из 10 элементов.Присвоить массиву D среднее арифметическое каждого элемента этих трех массивов.

Читайте также

помогите исправить ошибки.Масиви. Уплотнить линейный массив, удалив нули и сдвинув влево остальные элементы program

{ Уплотнить линейный массив удалив нули и сдвинув влево остальные элм.}

uses crt

var m,i,k:longint a:array[1..100]of longint

begin

clrscr

write('введите кол-во элм таблицы: ')redln(k)

for i=1 to k do

begin

write('a[',i,']=')redln(a[i])

end

m=0

for i=1 to k do

if a[i]=0 then inc(m)

elsey a[i-m]=a[i]k=k-m

for i=1 to k do write(a[i],' ')redln

end.

1. Линейный алгоритм.



Составить алгоритм вычисления
площади поверхности цилиндра S= 2*π*r(h+r).






Вы находитесь на странице вопроса "Исправьте ошибки пожалуйста Pascal!Линейные алгоритмы.Пара кроликов каждый год дает приплод двух (самку и самца) которые через 2 месяца способны давать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.