Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста я новичок и написал программу в паскале,но она почему то не идет.Подскажите,что я написал не так.

5-9 класс

нужно чтобы прямоугольник со сторонами a и b вошел или не вошел в фигуру со сторонами x,y,z
Program figures;
var a,b,x,y,z:integer;
begin
write('введите 5 чисел');
read(a,b,x,y,z);(написано когда запускаешь и пишешь цифры что не верный формат это строки)
if(a<x)and(b<y)and(a<z)then
write('войдет')else write('не войдет');
end.


Lizkala 28 дек. 2016 г., 21:51:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gosha200
29 дек. 2016 г., 0:03:37 (7 лет назад)

введите 5 чисел4 5 4 6 4
не войдет

все работает, числа через пробел вводи

+ 0 -
Рыбкаа
29 дек. 2016 г., 1:03:33 (7 лет назад)

Строку read(a,b,x,y,z);
замени на фрагмент:
readln(a);
readln(b);
readln(x);
readln(y);
readln(z);

Должно работать :)

Ответить

Другие вопросы из категории

Задача по Паскалю

Почтовый ящик superBat устроен так, что если первой фразой письма является приветствие "Hello!", то это приветствие пользователю не показывается. Напишите программу для работы этого почтового ящика. Ваша программа должна удалять из строки приветствие 'Hello!', если строка с него начинается и затем выводить измененную строку. (Будем также считать, что слова (HELLO, hELLO в начале письма невозможны).)
Входные данные
Вводится строка, не начинающаяся с пробела.

составить программу вычисления значения n!1,2,3,4,5,6 n=7

используя оператор FOR

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Срочно, помогите пожалуйста!

Написать программу в паскале. Цикл "пока".
Одноклеточная амёба каждые 3 часа делится на 2 клетки. Определить через сколько часов будет X амёб. X - вводится с клавиатуры.

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.



Вы находитесь на странице вопроса "Помогите пожалуйста я новичок и написал программу в паскале,но она почему то не идет.Подскажите,что я написал не так.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.