Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить алгоритм вычисления площади треугольника по формуле Герона

5-9 класс

Elizavetkamakarova 03 нояб. 2014 г., 11:57:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Даша199871
03 нояб. 2014 г., 13:09:37 (9 лет назад)

 АЛГОРИТМ ВЫЧИСЛЕНИЯ ПЛОЩАДИ ТРЕУГОЛЬНИКА ПО ФОРМУЛЕ ГЕРОНА.

 Площадь вычисляется по следующей формуле

 S=, где P= ;

A, B, C размеры сторон треугольника - аргументы;

S площадь треугольника - результат;

P полупериметр - промежуточная переменная;

Проверки:

    если A<=0 или B<=0 или C<=0

        то напечатать "размеры должны быть

                      положительные"

    все

 

    если A+B<=C или A+C<=B или C+B<=A

    |   то печать " нельзя составить треугольник"

    все

 

Program GERON:

  Uses crt;

  Var A,B,C:real;

Begin

  CLRSCR; TEXTCOLOR(1);

  WRITELN(‘ПЛОЩАДЬ ТРЕУГОЛЬНИКА.’);

  WRITELN(‘ПРОГРАММУ СОСТАВИЛА ИВАНОВА СВЕТА.’);

  WRITE(‘ВВЕДИТЕ РАЗМЕРЫ ТРЕХ СТОРОН: ’);

  READLN(A,B,C);

   IF (A<=0) OR (B<=0) OR (C<=0)

       THEN WRITELN (‘ЕСТЬ ОТРИЦАТЕЛЬНЫЕ РАЗМЕРЫ.’)

       ELSE IF (A+B<=C) OR (B+C<=A) OR (A+C<=B)

             THEN WRITELN(‘РАЗМЕРЫ НЕ ТРЕУГОЛЬНИКА.’)

             ELSE BEGIN

                   P:=(A+B+C)/2;

                   S:=SQRT(P*(P-A)*(P-B)*(P-C));

                   WRITELN(‘ПЛОЩАДЬ РАВНА:’, S);

                  END

 End.

 

Ответить

Читайте также

Составить программу нахождения площади треугольника по формуле Герона.

Входные данные длины сторон треугольника.
Выходные данные периметр треугольника, площадь треугольника.

1. Составьте блок-схему алгоритма и программу вычисления площади треугольника по трем сторонам. 2. Составьте программу вычисления объема, площади полной

поверхности, суммы ребер прямоугольного параллелепипеда. 3. Составьте программу вычисления диагоналей ромба по стороне и углу.

Составить алгоритм нахождения площади и длины окружности если известен радиус.

Составить алгоритм нахождения площади и длины окружности если известен диаметр.



Вы находитесь на странице вопроса "составить алгоритм вычисления площади треугольника по формуле Герона", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.