Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1. ЛАЗЕРНАЯ СИГНАЛИЗАЦИЯ 1 В процессе модернизации технического обеспечения и применения новых информационных

5-9 класс

технологий для защиты от воров вокруг банка поставили лазерную сигнализацию, которая состоит из нескольких лазерных станций. Станции ставятся по периметру здания, и между соседними станциями проходит лазерный луч. Также каждые соседние станции соединены кабелем. Известны координаты всех станций в порядке их обхода «по» или «против» часовой стрелки. Вам, как отличнику учебы, поручили ответственное задание – посчитать суммарную длину кабеля, который соединяет станции.

Входные данные

В первой строке находятся целое N – число базовых станций (1<=N<=2*10^6).

В следующих N строках – по два вещественных числа x, y (|x|<=10^4, |y|<=10^4), разделённых пробелом: координаты каждой станции (в прямоугольной декартовой системе координат).

Результат

Необходимо вывести суммарную длину кабеля, который потребуется проложить, с точностью до двух знаков после точки.


Примеры входных и выходных данных:

Входные данные 5 -1 -1 -1 1 1 1 2 0 1 -1

Выходные данные 8.83

NisYusa 11 авг. 2013 г., 14:26:07 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ivanresh
11 авг. 2013 г., 15:48:50 (10 лет назад)

var
n,i:integer;
x0,y0,x1,y1,x2,y2,s:real;
begin
readln(n);
s:=0;
readln(x0,y0);
x1:=x0;
y1:=y0;
for i:=2 to n do
begin
readln(x2,y2);
s:=s+sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
x1:=x2;
y1:=y2;
end;
x2:=x0;
y2:=y0;
s:=s+sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
writeln(s:10:2);
end.

Ответить

Читайте также

Каким термином называется концептуальная структура персонального компьютера, от которой зависит, каким образом будет проводиться обработка

информации, а также принципы взаимодействия технических средств и программного обеспечения? Это понятие в широком смысле определяется также как искусство проектирования различных сооружений.

Пожалуйста делайте те кто знает!!! 10 . Укажите номера основных устройств, которые вклю­чены в состав персональной ЭВМ:

1) системный блок 2) принтер 3) монитор 4) клавиатура.

11. Какие основные узлы компьютера располагаются в системном блоке?

1) монитор 2) дисковод 3) системная плата 4) манипулятор «мышь»

5) блок питания.

12 Определите, к какой категории программного обес­печения ПК относятся описанные программы:

1) выполняют различные вспомогательные функ­ции;

2) обеспечивают выполнение необходимых пользо­вателям работ: редактирование текстов; рисова­ние картинок и т.д.;

3) обеспечивают создание новых программ для ком­пьютера.

1. Системы программирования 2. Системные программы 3. Прикладные программы

13. Выберите, какие две задачи должна решать ОС:

1) Распределять время работы за компьютером каж­дого пользователя.

2) Организовать пользовательский интерфейс.

3) Проводить профилактический ремонт аппарату­ры.

4)Организовать совместную работу всех узлов ком­пьютера и выполнять обязанности диспетчера вы­числительного процесса.

14. Каким образом можно определить однопользова­тельские и многопользовательские ОС:

1) по числу одновременно решаемых задач;

2) по количеству пользователей;

3) по количеству процессоров.

15. Каждый файл, записанный на диске, имеет обозна­чение, состоящее из двух частей:

1) имени и расширения; 2) имени и даты создания;

3) имени и длины; 4) имени файла и имени диска.

16. Выберите имена файлов, содержащие программы, готовые к выполнению:

1) мас.ехе; 2) мас.txt; 3) маc.doc; 4) маc.bas; 5) маc.com.

17. Локальная сеть – это:

1) компьютерная сеть, работающая в пределах одного региона;

2) компьютерная сеть, работающая в пределах одной страны;

3) компьютерная сеть, работающая в пределах одного учреждения.

18. Для создания локальной сети необходимо:

1) сетевая плата, модем, сетевой кабель, сетевое программное обеспечение;

2) сетевая плата, сетевой кабель, сетевое программное обеспечение;

3) сетевая плата, сетевой кабель, сервер.

19. Укажите виды локальной сети:

1) на основе сервера, линейная шина, кольцевая;

2) звезда, линейная шина, кольцевая;

3) одноранговая, линейная шина, кольцевая;

20. Информация передается со скоростью 2,5 Кбайт/с. Какой объем информации будет передан за 20 мин.? Запишите результат в мегабайтах.

21. Программа просмотра гипертекстовых страниц WWW:

1) браузер; 2) протокол; 3) сервер; 4) HTML;

и т.д.



Вы находитесь на странице вопроса "1. ЛАЗЕРНАЯ СИГНАЛИЗАЦИЯ 1 В процессе модернизации технического обеспечения и применения новых информационных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.