Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Введите с клавиатуры два целых числа. Выведите на экран сумму чисел, разницу между числами, квадрат разности между числами, частное и остаток от

5-9 класс

деления первого числа на второе

BoBuK 30 янв. 2014 г., 20:31:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
аленка2020
30 янв. 2014 г., 22:55:32 (10 лет назад)

var
a, b: integer;

begin
readln(a, b);
writeln('Сумма чисел: ', a+b);
writeln('Разница между числами: ', abs(a-b));
writeln('Квадрат разности: ', sqr(a-b));
writeln('Частное: ', a div b);
writeln('Остаток от деления первого на второе: ', a mod b);
end.

Ответить

Другие вопросы из категории

Здравствуйте! Мы сделали кнопки в PascalABC.Net. Как сделать так, чтобы когда на них нажимаешь, то выводился на экран текст. Заранее спасибо.

Вот код программы:

uses GraphABC, ABCObjects,ABCButtons;

begin
MaximizeWindow;
var btword := new ButtonABC(50,125,500,100,'Играть',clWhite);
var btword1 := new ButtonABC(50,325,500,100,'Настройки',clWhite);
var btword2 := new ButtonABC(50,525,500,100,'Правила',clWhite);
var btword3 := new ButtonABC(50,725,500,100,'Выход',clWhite);
end.

Читайте также

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


Напишите следующую программу. Введите с клавиатуры целое число N. Выведите на экран числа от 1 до N так, чтобы каждое число выводилось столько раз, каково

его значение. Например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6
Написать программу нужно как можно проще в программе PascalABC

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел



Вы находитесь на странице вопроса "Введите с клавиатуры два целых числа. Выведите на экран сумму чисел, разницу между числами, квадрат разности между числами, частное и остаток от", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.