Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Разработать алгоритмы и программы для вычисления математических выражений на языке Turbo Pascal

5-9 класс

юля24 27 сент. 2013 г., 11:49:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nelgovka1
27 сент. 2013 г., 14:16:07 (10 лет назад)

var
  a, b, x, y: real;

begin
  Write('Введите через пробел значения a и b: ');
  Readln(a, b);
  if a < b then x := 2 * a * +2 * b
  else
  if a = b then x := 18
  else x := a * b - 45;
  Write('x=', x:0:5);
  if x <= 0 then Writeln(', при x<=0 вычислить y невозможно')
  else
  begin
    if (x > 0) and (x < 1) then y := x - ln(x) {в формуле log, но основание не указано}
    else y := ln(x) + x;
    Writeln(', y=', y:0:5)
  end
end.

Тестовое решение:

Введите через пробел значения a и b: 3 6.4
x=76.80000, y=81.14120

Введите через пробел значения a и b: 8 4
x=-13.00000, при x<=0 вычислить y невозможно



Ответить

Читайте также

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)



Вы находитесь на странице вопроса "Разработать алгоритмы и программы для вычисления математических выражений на языке Turbo Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.