Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано натуральное число N. Определить К - количество делителей этого

5-9 класс

числа, не превышая его ( N = 12, его делители 1, 2, 3, 4, 6, К = 5 )

Sewh 03 апр. 2014 г., 6:37:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bellasugra
03 апр. 2014 г., 8:00:23 (10 лет назад)

program qq;
var h,k,i,n:integer;
begin
readln ( n);
for i:= 1 to n do
begin
k:= n mod i;
if k = 0 then
h:= h+1;
end;
writeln (h);
end.
к тому же у 12 еще "12" делитель, поэтому к = 6

+ 0 -
Sonchik82
03 апр. 2014 г., 9:42:24 (10 лет назад)

uses crt;
var n,i,k:integer;
begin
read(n);
for i:=1 to n-1 do
if i mod k=0 then
k:=k+1;
writeln(k);
end.

Ответить

Другие вопросы из категории

СРОЧНО !

НАПИШИТЕ ПРОГРАММУ НА ПАСКАЛЕ ВВОДА С КЛАВИАТУРЫ ДВУХ ЧИСЕЛ И ВЫВОДА НА ЭКРАН ЧИСЛА , ЧЕЙ КВАДРАТ БОЛЬШЕ

слова з літер слова презинтація

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

задача 1. Дано натуральное число n. Напишите программу выводящую на экран последовательность натуральных чисел от 1 до n. задача 2. Даны

натуральные числа A , B, где B>A. Напишите программу последовательность натуральных чисел от A до B, включающая A и B.

Пожалуйста помогите !!!!!!!!



Вы находитесь на странице вопроса "Дано натуральное число N. Определить К - количество делителей этого", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.