Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу в Паскале, которая получает три числа и выводит количество натуральных одинаковых чисел в этой цепочке. пример: введите три

5-9 класс

чила:

5 5 5

все числа одинаковые.

спасибо

Azapik 08 февр. 2015 г., 23:00:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Selenas1
09 февр. 2015 г., 1:39:53 (9 лет назад)

Если в три переменные:
var a,b,c:integer;
begin
writeln ('Введите 3 числа');
read (a,b,c);
if (a=b)or (a=c) or (b=c) then
begin
if (a>1) and (b>1) and (c>1)and (a=b) and (a=c) and (b=c) then //Одно ненужное условие для наглядности
writeln ('Все числа одинаковые');
if ((a>1) and (b>1) and (a=b)) or ((a>1) and (c>1) and (a=c)) or ((b>1) and (c>1) and (b=c)) then writeln (2);
end
else writeln ('Нет одинаковых чисел');
end.


+ 0 -
Volody5
09 февр. 2015 г., 2:32:52 (9 лет назад)

числа вводятся в одну переменную или в три?

Ответить

Другие вопросы из категории

Информатика - это наука...

География - это наука...
Фонетика - это раздел науки о...
Ботаника - это раздел науки о...
Имя существительное - это самостоятельная часть речи,...
Глагол - это самостоятельная часть речи,...
Земледельцы - это люди...
Животноводы - это люди...
Тяжелая промышленность - это...
Легкая промышленность - это...

Сосуды цилиндрической формы заполнены до краёв жидкостью плотностью d=1200кг\м³. Составьте программу, которая вычисляет давление столба жидкости

на дно сосудов p=dgh( g=9,8м\с²)

6 сосудов( высота 1сосуда 7, высота 2 сосуда 4, высота 3 сосуда 10, высота 4 сосуда 6, высота 5 сосуда 5, высота 6 сосуда 3)

Читайте также

1)напишите программу которая спрашивала бы название продукта и его цену. И затем на экран выводила фразу "Ваши расходы на покупки равны руб." 2) написать

программу, которая запрашивала три числа, подсчитывала их средне и сумму и на экран выводила фразу "Их среднее равно..." и "Их сумма равна..."

1.Составить программу в паскале,которая предлагает Ивану -Царевичу выбрать правильное направление пути.У Ивана-Царевича есть три варианта дальнейшего

пути:

направо,-"Коня потеряешь"

налево,-"голову сложишь"

вперёд,-"невесту найдёшь"

2.Составить прогрмму,которая определяет положительное число или отрицательное.

3.Дано целое число А.Если значение А>0,то необходимо его уыеличить на единицу.Если В<0,то уменьшить на единицу.

Зарание спасибо :)

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.



Вы находитесь на странице вопроса "Напишите программу в Паскале, которая получает три числа и выводит количество натуральных одинаковых чисел в этой цепочке. пример: введите три", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.