Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу вычисления выражения с помощью цикла for 1!+2!+3!+...+n!

5-9 класс

уже не соображаю..

Nikita2256 19 марта 2014 г., 0:55:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Desy
19 марта 2014 г., 2:23:15 (10 лет назад)

 var \ i,n,s:integer; \\\\*function \ fact(a:integer):integer; \\\\*begin \\\\* \ if \ a<=1 \ then \ fact:=1 \\\\* \ else \ fact:=a*fact(a-1); \\\\*end; \\\\* \\\\*begin \\\\* \ writeln('Vvedite \ n \ '); \\\\* \ readln(n); \\\\* \ for \ i:=1 \ to \ n \ do \ s:=s+fact(i); \\\\* \ writeln('Summa \ ravna \ ',s); \\\\*end. \\\\* \

Ответить

Другие вопросы из категории

Заполнить двумерный массив

и вывести его на печать в виде


1 0 0 0 0


0 1 0 0 0


0 0 1 0 0


0 0 0 1 0


0 0 0 0 1


Подсказка;надо ввести условия для вывода
1,а в остальных случаях выводится 0

Читайте также

Напишите программу в PascalABC с помощью которой рисуется движущийся

рисунок (должно двигаться не менее трех частей) , например - машина с
вращающимися колесами, с помощью цикла for и простых команд
(использовать GraphABC).

Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). Программист торопился и

написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится пять ошибок:

k:=1;

f:=0;

while k<n do

f:=f*k;

k:=k+1

Написать программу Turpo pascal помогите пожалуйста что сможете!!! Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу

вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.

Определение факториала:

0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.

Другими словами n!- это произведение n натуральных чисел.



Вы находитесь на странице вопроса "написать программу вычисления выражения с помощью цикла for 1!+2!+3!+...+n!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.