Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составить программу, которая сравнивает два действительных числа x, y (xy), введенных с клавиатуры, и меньшее из них заменяет их полусуммой, а большее

10-11 класс

- их удвоенным произведением.

Johon1090 29 янв. 2015 г., 9:41:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Make5
29 янв. 2015 г., 12:13:15 (9 лет назад)

var a,b:real;

Begin

  read(a,b);

  if a>b then begin

    a:=2*(a+b);

    b:=a/4;

  end;

  else begin

    b:=2*(a+b);

    a:=b/4;

  end;

  writeln(a,b);

End.

Ответить

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

Объясните как делать : составить программу которая сравнивает два числа

введенные с клавиатуры и выводит на экран большее .

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))



Вы находитесь на странице вопроса "Составить программу, которая сравнивает два действительных числа x, y (xy), введенных с клавиатуры, и меньшее из них заменяет их полусуммой, а большее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.