Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан двумерный массив 6х4. Пощетать количество элементов во всем массиве которые кратны 3.

10-11 класс

пуффиcтиk 23 июля 2014 г., 15:20:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
фатина24
23 июля 2014 г., 16:07:43 (9 лет назад)

Program Program1;
var
i,j,k:integer;
A: array [1..6,1..4] of integer;
begin
randomize;
for i:=1 to 6 do
for j:=1 to 4 do
a[i,j]:=random(100);
k:=0;
for i:=1 to 6 do
for j:=1 to 4 do
if a[i,j] mod 3 = 0 then inc(k);
writeln('Кратны трем ',k,' элем.');
end.

Ответить

Другие вопросы из категории

Помогите построить блок-схему для программы Pascal:

var
n, i, j: integer;
begin
read(n);
for i := 1 to n - 1 do
for j := i to n - 1 do
if i * i + j * j <= n then
writeln(i,'^2 + ',j,'^2 = ',i * i + j * j);
end.

В электронной таблице значение

формулы =CP3HAЧ(D1:D4) равно 5. Чему равно значе­ние ячейки D1, если значение формулы =СУММ(D2:D4) равно 12?

1) Написать программу, которая определяет номера строк двумерного массива A[1..6,1..4], в которых содержится хотя бы один нулевой элемент. 2) 5. Составить

программу заполнения массива B[1..10] таким образом: элементы с нечетными индексами равны числу 2, а элементы с четными индексами равны числу 5.

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Дан Двумерный массив из n×m элементов (N,М≤ 100) a11, a12 , ..., a1N ; am1, am2

, ..., amN.. Найти сумму элементов на нечетных местах массива и произведение элементов на четных местах массива.

дан массив из 30-ти элементов. Каждый элемент может принимать целочисл

енные значения от -100 до 100. Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. Первый элемент не равен 0. (Паскаль)

Дан целочисленный массив из 10 элементов.Элементы массива могут принимать целые значения от -50 до 50.Составить программу ,позволяющую найти и

вывести сумму элементов массива которые кратны 7 и оканчиваются на 5 .Гарантируется,что в исходном массиве есть хотя бы один такой элемент.
НА ЯЗЫКЕ ПАСКАЛЬ!!!!



Вы находитесь на странице вопроса "Дан двумерный массив 6х4. Пощетать количество элементов во всем массиве которые кратны 3.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.